Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-08-22 09:43:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-08-22 09:43:58 +0200
commit369543cc36e9e8c0250234b7e450a4673bdfb868 (patch)
treebd7b3907284faa7fb6e43c4361267a2dac1de596 /extra
parentb8b7ce74bca0c6036c77bb4b3f1decbda6b1ec25 (diff)
extra/mesa: SSE2 is the default now, disable it on i686 and i486
Diffstat (limited to 'extra')
-rw-r--r--extra/mesa/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index 9978cced..1a4ca069 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -130,3 +130,13 @@ if [ "$CARCH" = 'i486' ]; then
depends+=(libxshmfence)
depends+=(wayland)
fi
+
+# defaults changed to SSE2 enabled by default, disable it
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Dsse2=false /
+ '
+ )"
+fi