Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-08-23 23:49:35 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-08-23 23:49:35 +0300
commit2b9627ee087150c867f78abd352b9de6a95e573e (patch)
treeca82858158ece75224a250072cf99321d8d7c60c /extra
parent9f811c914d10a6391dc8de0971453d7aca7081e5 (diff)
extra/stochas: Enable SSE for i686
Diffstat (limited to 'extra')
-rw-r--r--extra/stochas/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/stochas/PKGBUILD b/extra/stochas/PKGBUILD
index 64b12253..734814d5 100644
--- a/extra/stochas/PKGBUILD
+++ b/extra/stochas/PKGBUILD
@@ -1 +1,12 @@
+# This requires SSE, so enable it on i686
+
+if [ "$CARCH" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ 3 i export CXXFLAGS="$CXXFLAGS -msse" CFLAGS="$CFLAGS -msse"
+ '
+ )"
+fi
+
eval "$(declare -f package_stochas-vst3 | sed 's@\$CARCH@i386@g')"