Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-05-15 13:57:23 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-05-15 13:57:23 +0200
commit158567319aed99ea9dfb2eee6e628cc916222ed4 (patch)
treeb948f44f3c77ba7474c7694aac70f2ea44efefae /extra
parent26622a257dbd84882826cd47f8355429451b9abb (diff)
extra/ffmpeg: do not build with libvamf on non-pentium4
Diffstat (limited to 'extra')
-rw-r--r--extra/ffmpeg/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/ffmpeg/PKGBUILD b/extra/ffmpeg/PKGBUILD
new file mode 100644
index 00000000..483b4b58
--- /dev/null
+++ b/extra/ffmpeg/PKGBUILD
@@ -0,0 +1,19 @@
+# no vamf for non-pentium4
+if [ "$CARCH" == 'i686' ] || [ "$CARCH" == 'i486' ]; then
+ depends=(${depends[@]//vmaf/})
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /vmaf/d
+ '
+ )"
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-libvmaf/--disable-libvmaf/
+ '
+ )"
+
+fi