Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/xorg-server
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-05-16 11:14:11 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-05-16 11:14:11 +0300
commit3573a39ccf2ca68eb54279d59472153cd195b635 (patch)
tree68e09ffc2fdeb08ecf6e761029f75d3730a96505 /extra/xorg-server
parent4c85e6a3691a18420de8e2f5305a12f8c26cde4e (diff)
extra/xorg-server: Delete old and backport new patch
Diffstat (limited to 'extra/xorg-server')
-rw-r--r--extra/xorg-server/0001-ephyr-Fix-incompatible-pointer-type-build-error.patch54
-rw-r--r--extra/xorg-server/PKGBUILD15
-rw-r--r--extra/xorg-server/xorg-server-21.1.3-probed-mode-name-not-null.patch18
3 files changed, 59 insertions, 28 deletions
diff --git a/extra/xorg-server/0001-ephyr-Fix-incompatible-pointer-type-build-error.patch b/extra/xorg-server/0001-ephyr-Fix-incompatible-pointer-type-build-error.patch
new file mode 100644
index 00000000..452723ee
--- /dev/null
+++ b/extra/xorg-server/0001-ephyr-Fix-incompatible-pointer-type-build-error.patch
@@ -0,0 +1,54 @@
+From e89edec497bac581ca9b614fb00c25365580f045 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Exp=C3=B3sito?= <jexposit@redhat.com>
+Date: Fri, 19 Jan 2024 13:05:51 +0100
+Subject: [PATCH] ephyr: Fix incompatible pointer type build error
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fix a compilation error on 32 bits architectures with gcc 14:
+
+ ephyr_glamor_xv.c: In function ‘ephyr_glamor_xv_init’:
+ ephyr_glamor_xv.c:154:31: error: assignment to ‘SetPortAttributeFuncPtr’ {aka ‘int (*)(struct _KdScreenInfo *, long unsigned int, int, void *)’} from incompatible pointer type ‘int (*)(KdScreenInfo *, Atom, INT32, void *)’ {aka ‘int (*)(struct _KdScreenInfo *, long unsigned int, long int, void *)’} [-Wincompatible-pointer-types]
+ 154 | adaptor->SetPortAttribute = ephyr_glamor_xv_set_port_attribute;
+ | ^
+ ephyr_glamor_xv.c:155:31: error: assignment to ‘GetPortAttributeFuncPtr’ {aka ‘int (*)(struct _KdScreenInfo *, long unsigned int, int *, void *)’} from incompatible pointer type ‘int (*)(KdScreenInfo *, Atom, INT32 *, void *)’ {aka ‘int (*)(struct _KdScreenInfo *, long unsigned int, long int *, void *)’} [-Wincompatible-pointer-types]
+ 155 | adaptor->GetPortAttribute = ephyr_glamor_xv_get_port_attribute;
+ | ^
+
+Build error logs:
+https://koji.fedoraproject.org/koji/taskinfo?taskID=111964273
+
+Signed-off-by: José Expósito <jexposit@redhat.com>
+---
+ hw/kdrive/ephyr/ephyr_glamor_xv.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/hw/kdrive/ephyr/ephyr_glamor_xv.c b/hw/kdrive/ephyr/ephyr_glamor_xv.c
+index 4dd15cf417..b5eae48c85 100644
+--- a/hw/kdrive/ephyr/ephyr_glamor_xv.c
++++ b/hw/kdrive/ephyr/ephyr_glamor_xv.c
+@@ -50,16 +50,16 @@ ephyr_glamor_xv_stop_video(KdScreenInfo *screen, void *data, Bool cleanup)
+
+ static int
+ ephyr_glamor_xv_set_port_attribute(KdScreenInfo *screen,
+- Atom attribute, INT32 value, void *data)
++ Atom attribute, int value, void *data)
+ {
+- return glamor_xv_set_port_attribute(data, attribute, value);
++ return glamor_xv_set_port_attribute(data, attribute, (INT32)value);
+ }
+
+ static int
+ ephyr_glamor_xv_get_port_attribute(KdScreenInfo *screen,
+- Atom attribute, INT32 *value, void *data)
++ Atom attribute, int *value, void *data)
+ {
+- return glamor_xv_get_port_attribute(data, attribute, value);
++ return glamor_xv_get_port_attribute(data, attribute, (INT32 *)value);
+ }
+
+ static void
+--
+GitLab
+
diff --git a/extra/xorg-server/PKGBUILD b/extra/xorg-server/PKGBUILD
index f30c30dd..68846353 100644
--- a/extra/xorg-server/PKGBUILD
+++ b/extra/xorg-server/PKGBUILD
@@ -1,18 +1,13 @@
-# backport of ed11c4d443ad2e82512df64358d38008e0ee7693 for initializing probed mode line names
-source+=('xorg-server-21.1.3-probed-mode-name-not-null.patch')
-sha512sums+=('d721fad70b417b40f6b29e77b21c530b8f6d91c37e65c1a82c2cfcde5012adc17022ac0faa50ca587583aab6f6a5e5bdcdc68e36ece6ada766813aca1ab8b76d')
+source+=('0001-ephyr-Fix-incompatible-pointer-type-build-error.patch')
+sha512sums+=('5d6e2063d2e4d97dd2883b11ab7953e8ddedf5389b2e510e85ff199eebb86ad43c74ab88dc9258290bff91ed7c6ceefc0f90b148846b9703b1ce7c782905424a')
eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/$pkgname-$pkgver" \
- patch -Np1 -i "$srcdir/xorg-server-21.1.3-probed-mode-name-not-null.patch"
+ declare -f prepare | sed '
+ 4i patch -Np1 -i "$srcdir/0001-ephyr-Fix-incompatible-pointer-type-build-error.patch" || true
'
)"
+
# disabling LTO on i486 as enabling it leads to all kind of link errors
if [ "${CARCH}" = "i486" ]; then
eval "$(
diff --git a/extra/xorg-server/xorg-server-21.1.3-probed-mode-name-not-null.patch b/extra/xorg-server/xorg-server-21.1.3-probed-mode-name-not-null.patch
deleted file mode 100644
index 77d5de33..00000000
--- a/extra/xorg-server/xorg-server-21.1.3-probed-mode-name-not-null.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -rauN xorg-server-21.1.3/hw/xfree86/modes/xf86Modes.c xorg-server-21.1.3-probed-mode-name-not-null-patch/hw/xfree86/modes/xf86Modes.c
---- xorg-server-21.1.3/hw/xfree86/modes/xf86Modes.c 2022-03-05 19:16:34.732713684 +0100
-+++ xorg-server-21.1.3-probed-mode-name-not-null-patch/hw/xfree86/modes/xf86Modes.c 2022-03-05 19:17:39.749449014 +0100
-@@ -803,10 +803,14 @@
- {
- struct libxcvt_mode_info *libxcvt_mode_info;
- DisplayModeRec *Mode = xnfcalloc(1, sizeof(DisplayModeRec));
-+ char *tmp;
-
- libxcvt_mode_info =
- libxcvt_gen_mode_info(HDisplay, VDisplay, VRefresh, Reduced, Interlaced);
-
-+ XNFasprintf(&tmp, "%dx%d", HDisplay, VDisplay);
-+ Mode->name = tmp;
-+
- Mode->VDisplay = libxcvt_mode_info->vdisplay;
- Mode->HDisplay = libxcvt_mode_info->hdisplay;
- Mode->Clock = libxcvt_mode_info->dot_clock;