Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/tracker3/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-11-11 19:35:13 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-11-11 19:35:13 +0100
commitee10b823c6bfc5b98cf9e1d3645b1f3a8901282b (patch)
tree735988177e7189fe0afb8d4348ed5008fbc9a5ff /extra/tracker3/PKGBUILD
parent78535a11605a86fbe240dce517b0d6e86f4f0018 (diff)
extra/tracker3: tried to build without documenrtation (because buildign the documentation fails)
Diffstat (limited to 'extra/tracker3/PKGBUILD')
-rw-r--r--extra/tracker3/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/extra/tracker3/PKGBUILD b/extra/tracker3/PKGBUILD
index 7c5c36eb..a25ec7c2 100644
--- a/extra/tracker3/PKGBUILD
+++ b/extra/tracker3/PKGBUILD
@@ -21,3 +21,26 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# Don't care about broken uptream stuff, especially if it all it does
+# is documenration:
+# tracker/docs/reference/libtracker-sparql/meson.build:63:7: ERROR: hotdoc.generate_doc
+# keyword argument 'dependencies' was of type array[CustomTarget | InternalDependency]
+# but should have been array[Dependency | StaticLibrary | SharedLibrary
+eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson/arch-meson -D docs=false/
+ '
+)"
+
+# more no-doc patching
+source+=('tracker-no-doc.patch')
+sha256sums+=('2621451f3dc44ad458934c6c2cbdf27d73f94e6470082b3f01b5ffb6d752deda')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /}/ i \
+ patch -Np1 < ${srcdir}/tracker-no-doc.patch
+ '
+)"