Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/tbb/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-03-17 09:33:08 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-03-17 09:33:08 +0100
commit860055a5f5938523312847a9fbb9fc0377060435 (patch)
treefb437eac16dc985f327761ea1cfd77da8afd13bb /extra/tbb/PKGBUILD
parentae361398ea855fc6cb4e8c5622f7c335e4c62727 (diff)
extra/onetbb: renamed upstream from tbb
Diffstat (limited to 'extra/tbb/PKGBUILD')
-rw-r--r--extra/tbb/PKGBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/extra/tbb/PKGBUILD b/extra/tbb/PKGBUILD
deleted file mode 100644
index ea8c3d64..00000000
--- a/extra/tbb/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# disable waitpkg extensions (error is inline failing in _tpause)
-# (see https://github.com/oneapi-src/oneTBB/issues/370 and
-# https://github.com/oneapi-src/oneTBB/pull/609/commits/542a27fa1cfafaf76772e793549d9f4d288d03a9)
-source+=('oneTBB-2021.5.0-no-waitpkg.patch')
-sha512sums+=('918cb0418118de415eb9a7872a4938d15aec8b1ea096bc2996bc7390cd9c73cdc551f15a590b518ec1decfb458d8a488338625a81c26287cba184352fb950f16')
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() { cd ${srcdir}/oneTBB-${pkgver}\n}\n'
- } \
- | sed '
- $i patch -d "${srcdir}/oneTBB-${pkgver}" -p1 -i "$srcdir/oneTBB-2021.5.0-no-waitpkg.patch"
- '
-)"
-
-# -latomic on i486
-if [ "$CARCH" == 'i486' ]; then
- eval "$(
- declare -f build | \
- sed '
- s/cmake /cmake -DCMAKE_CXX_STANDARD_LIBRARIES=-latomic /
- '
- )"
-fi
-
-# just for now we don't test on i486, we have to do real tests on a
-# real old CPU, in chroots the tests are running, on the real thing
-# they hang (presumably some opcodes are missing or not doing exactly
-# what they do in emulation)..
-# for now it's more important to unstuck the package and build the
-# rest on top
-if [ "$CARCH" == 'i486' ]; then
- unset check
-fi
-
-# ignore some errors in test
-if [ "$CARCH" == 'i486' ]; then
- eval "$(
- declare -f build | \
- sed '
- /CXXFLAGS/ a export CXXFLAGS="$CXXFLAGS -Wno-error=array-bounds -Wno-error=use-after-free"
- '
- )"
-fi