Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-20 16:12:10 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-20 16:12:10 +0200
commitabc41e4d2d8bf65d9793cc609d6f77c76e206b8a (patch)
tree0c15016def78b103921ff07e444b2f249376a0d6 /extra/rust
parent896345395fa37af244b766298951cbaaeddc5a61 (diff)
extra/rust: Use ld.gold for LLVM
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD3
-rw-r--r--extra/rust/config.toml.patch9
2 files changed, 6 insertions, 6 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 3c05af70..df5cf3a0 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -43,8 +43,7 @@ eval "$(
/ln.*i686-unknown-linux-gnu.*/d
/_pick.*dest-i686.*/d
s/x86_64-unknown-linux-musl/i686-unknown-linux-musl/
- ' | \
- sed '3i export LDFLAGS="${LDFLAGS} -Wl,--reduce-memory-overheads"'
+ '
)"
eval "$(
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index 7072338a..43575b80 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,10 +1,11 @@
--- a/config.toml 2024-03-12 15:14:24.314876558 +0000
-+++ b/config.toml 2024-03-12 15:19:45.471512723 +0000
-@@ -3,14 +3,14 @@
++++ b/config.toml 2024-03-20 14:09:23.793371221 +0000
+@@ -3,14 +3,15 @@
[llvm]
link-shared = true
+link-jobs = 1
++use-linker = "/usr/sbin/ld.gold"
[build]
target = [
@@ -18,7 +19,7 @@
]
cargo = "/usr/bin/cargo"
rustc = "/usr/bin/rustc"
-@@ -37,7 +37,7 @@
+@@ -37,7 +38,7 @@
prefix = "/usr"
[rust]
@@ -27,7 +28,7 @@
channel = "stable"
description = "Arch Linux :-"
rpath = false
-@@ -74,7 +74,7 @@
+@@ -74,7 +75,7 @@
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"