Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-12 17:26:12 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-12 17:26:12 +0200
commit526573c0fe00ea3a50633aace86e28d8c54dd565 (patch)
tree4dac94eeeea3614379289259f0e84e1653ec08e3 /extra/rust
parentce4b65ee38e2b9b392574817e718dc015fcfb8dc (diff)
extra/rust: Try to reduce memory usage when linking llvm
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD2
-rw-r--r--extra/rust/config.toml.patch17
2 files changed, 11 insertions, 8 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index e2e8e38f..66659981 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-b2sums+=('27922f26ca7fadf6b35a9a94f988f7985c752149043424c62d9e5a908dd5779c73f775d04c3ef92a0daabf2f681e5e2ce6c1c173594613b91f6b1b79c7a8f16c')
+b2sums+=('7c1e3491dd5de9648b1f62abc6638e0bcc42c23370ef24f788e114261d823ebfec1ba09445c3214fed9e019adc39e38f2b2a021b7eb7492d4b6be6d4bb6c36f2')
eval "$(
declare -f prepare | \
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index d0a351bb..7072338a 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,7 +1,10 @@
-diff -rauN a/config.toml b/config.toml
---- a/config.toml 2023-01-22 09:04:27.684167483 +0100
-+++ b/config.toml 2023-01-22 09:05:53.794297289 +0100
-@@ -6,11 +6,10 @@
+--- a/config.toml 2024-03-12 15:14:24.314876558 +0000
++++ b/config.toml 2024-03-12 15:19:45.471512723 +0000
+@@ -3,14 +3,14 @@
+
+ [llvm]
+ link-shared = true
++link-jobs = 1
[build]
target = [
@@ -15,16 +18,16 @@ diff -rauN a/config.toml b/config.toml
]
cargo = "/usr/bin/cargo"
rustc = "/usr/bin/rustc"
-@@ -28,7 +27,7 @@
+@@ -37,7 +37,7 @@
prefix = "/usr"
[rust]
-debuginfo-level-std = 2
+debuginfo-level-std = 0
channel = "stable"
- description = "Arch Linux rust 1:1.66.1-2"
+ description = "Arch Linux :-"
rpath = false
-@@ -61,7 +60,7 @@
+@@ -74,7 +74,7 @@
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"