Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/re2/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-05-16 17:38:10 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-05-16 17:38:10 +0200
commit69ba4fe06e485fdf0d22eb068abf551b0211625f (patch)
treeae1f589ab7d5d8f96b068eb547815fcd822afab0 /extra/re2/PKGBUILD
parent0e4d7f8fa76c0d58f8f898a15eee91c09496b044 (diff)
extra/re2: patch for failing compile-test
Diffstat (limited to 'extra/re2/PKGBUILD')
-rw-r--r--extra/re2/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/re2/PKGBUILD b/extra/re2/PKGBUILD
new file mode 100644
index 00000000..1cd34742
--- /dev/null
+++ b/extra/re2/PKGBUILD
@@ -0,0 +1,17 @@
+# compiler-test fails in InsufficientMemory test due to the change of
+# the size of the DFA
+# bug: https://github.com/google/re2/issues/256
+# patch: https://github.com/google/re2/commit/bde1ea09550a61b4a092cdf0e3ba8dca4200947a
+source+=('re2-2020-05-01-compile-test-out-of-memory-fix.patch')
+sha256sums+=('bef199b3c77cd6477d9f3950acc5d017ce4a53e447827f01a4706e7e8980b220')
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $ i cd "$pkgname-$_re2ver"; patch -Np1 -i "${srcdir}"/re2-2020-05-01-compile-test-out-of-memory-fix.patch
+ '
+)"
+