Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/qemu
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-16 03:19:23 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-16 05:47:11 +0200
commita9f1555a407f3d891323beb13ac9a2dfbdd03b90 (patch)
tree016e9b33ec57a33a39c0998a4ea40f7391cc45dc /extra/qemu
parent98ac7751d2a8a616cd2efe2265e90ce1bb1e1bf5 (diff)
extra/qemu: Ignore failing manpage symlinks
Okay, this time I could test it and it does work.
Diffstat (limited to 'extra/qemu')
-rw-r--r--extra/qemu/PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/extra/qemu/PKGBUILD b/extra/qemu/PKGBUILD
index febd71e4..fc07d90f 100644
--- a/extra/qemu/PKGBUILD
+++ b/extra/qemu/PKGBUILD
@@ -1,4 +1,4 @@
-# ceph doesn't run on 32-xit currently (see FS32#21)
+# ceph doesn't run on 32-bit currently (see FS32#21)
makedepends=(${makedepends[@]/ceph})
@@ -27,5 +27,10 @@ eval "$(
# We'll live with invalid symlinks for now
eval "$(
declare -f package_qemu-common | \
- sed 's@usr/share/man/man.*;@\0 || true;@'
+ sed 's@\(usr/share/man/man.*\);@\1 || true;@ ; s@\(.*usr/share/doc/qemu.*\);@\1 || true;@'
+)"
+
+eval "$(
+ declare -f package_qemu-docs | \
+ sed 's@\(mv -v $pkgname/*.*\);@\1 || true;@'
)"