Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-setuptools
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-08 15:23:17 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-08 15:23:17 +0200
commit0b71c3bd5fa0eca7273d84257d6cfdfa0023dde7 (patch)
tree3c94eac616445ee869858696f9bd34239547ddf9 /extra/python-setuptools
parentbac778e7e3d3fb9e2de20c83674ac81055681f0b (diff)
Revert "extra/python-setuptools: Remove temporarily"
This reverts commit bac778e7e3d3fb9e2de20c83674ac81055681f0b.
Diffstat (limited to 'extra/python-setuptools')
-rw-r--r--extra/python-setuptools/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
new file mode 100644
index 00000000..63552ad5
--- /dev/null
+++ b/extra/python-setuptools/PKGBUILD
@@ -0,0 +1,40 @@
+# WARNING! If you get an error along the lines of
+# "error: cannot copy tree 'build/scripts-3.11': not a directory", STOP!
+#
+# You might be tempted, but do *NOT* `mkdir build/scripts-3.XX`.
+#
+# This happens because upstream is using the git repo which doesn't have the metadata.
+# It doesn't affect upstream because their setuptools already has a directory .egg-info,
+# whereas if we have an .egg-info file, then it will result in "error: invalid command 'egg_info'"
+# when trying to build any python package that uses setuptools.
+#
+# That said, let's build from the source tarball which already has the metadata.
+
+# Add the tarball
+source[0]="https://pypi.python.org/packages/source/s/setuptools/setuptools-$pkgver.tar.gz"
+# Depending on how annoying this gets, maybe comment it to switch back to SKIP
+sha512sums[0]='11df934931f4b73f7e07ea5713479593c6baa134d423556b2ae7aff0f1e5bdbdee1f5b516131adb169c838231ceb0293441fbf275ef7030dabecf74122565b6d'
+
+# Work around the directory name containing the version.
+eval "$(
+ declare -f prepare | \
+ sed -r 's/cd setuptools;?$/cd setuptools-$pkgver/'
+)"
+eval "$(
+ declare -f build | \
+ sed -r 's/cd setuptools;?$/cd setuptools-$pkgver/'
+)"
+eval "$(
+ declare -f package | \
+ sed -r 's/cd setuptools;?$/cd setuptools-$pkgver/'
+)"
+
+# Skip the last two patches.
+eval "$(
+ declare -f prepare | \
+ sed '/add-dependency.patch/d' | sed '/build-no-isolation.patch/d'
+)"
+
+# Don't bother with the tests.
+unset check
+unset checkdepends