Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-pygments/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-01-13 21:12:07 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-01-13 21:12:07 +0200
commit56771f4b085fa325408bef499f5cf4151c05f85e (patch)
treed2e2a1ca7c31186811d797f4c7582da5975f39e3 /extra/python-pygments/PKGBUILD
parentd2adc57df4fa7e5b64f0ccdc4e1fa398df5fd881 (diff)
extra/python-pygments: Remove sphinx dependency
Diffstat (limited to 'extra/python-pygments/PKGBUILD')
-rw-r--r--extra/python-pygments/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/python-pygments/PKGBUILD b/extra/python-pygments/PKGBUILD
new file mode 100644
index 00000000..9aaea430
--- /dev/null
+++ b/extra/python-pygments/PKGBUILD
@@ -0,0 +1,17 @@
+# Do not require sphinx because sphinx requires pygments
+
+makedepends=(${makedepends[@]//python-sphinx/})
+
+eval "$(
+declare -f build | \
+ sed '
+ s/make.*html//
+ '
+)"
+
+eval "$(
+declare -f package | \
+ sed '
+ s/cp.*doc.*html.*//
+ '
+)"