Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-pip/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-07-07 11:19:02 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-07-07 11:19:02 +0200
commit0510d974b4131736041fb314d1996a3ef14d5c2e (patch)
treee9abcd2065e171d769443ff2452d03cb0c136103 /extra/python-pip/PKGBUILD
parent4e5b06a20ec335846c1b9fffe4610057cbcfc496 (diff)
extra/pip: simplified bootstrapping without sphinx
Diffstat (limited to 'extra/python-pip/PKGBUILD')
-rw-r--r--extra/python-pip/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/extra/python-pip/PKGBUILD b/extra/python-pip/PKGBUILD
index 77266044..794fb07d 100644
--- a/extra/python-pip/PKGBUILD
+++ b/extra/python-pip/PKGBUILD
@@ -1,8 +1,12 @@
-# no python-sphinx
-makedepends=(${makedepends[@]/python-sphinx-inline-tabs/})
-makedepends=(${makedepends[@]/python-sphinx-copybutton/})
-makedepends=(${makedepends[@]/python-sphinxcontrib-towncrier/})
-makedepends=(${makedepends[@]/python-sphinx/})
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
eval "$(
declare -f build | \
sed '