Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/openal
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-06-20 19:11:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-06-20 19:11:58 +0200
commit11d2a3445315dd6e8e3388beb5cc94ce26cd8c88 (patch)
treec5e284aa8ddd163141579af29ea5829b0e989fc0 /extra/openal
parente77373793fa7eb886002e426ada139a714d95213 (diff)
extra/openal: removed i686 patch, seems fixed upstream, also using b2sums
Diffstat (limited to 'extra/openal')
-rw-r--r--extra/openal/PKGBUILD6
-rw-r--r--extra/openal/openal-i686.patch68
2 files changed, 2 insertions, 72 deletions
diff --git a/extra/openal/PKGBUILD b/extra/openal/PKGBUILD
index 4318ba27..9360d8e1 100644
--- a/extra/openal/PKGBUILD
+++ b/extra/openal/PKGBUILD
@@ -1,8 +1,8 @@
# disable Intel micro-optimizations and intrinsics per platform
# patch done by KitsuWhooa, thanks (see https://github.com/kcat/openal-soft/pull/559)
source+=('openal-i686.patch')
-sha512sums+=(
- '41e4134fea907d2f9b95eb496fde5eb7ce4bd8bfa1ad97c8d1a88b4454846195a1725c5bab047981e795d25eb29959e07fa349b212c24bbc86c06a597ac43e78'
+b2sums+=(
+ '2a3900e993916b928fae3515e76120f3ec9e7f6c893b0b29706cf2cbd0d2688ddacd90f4f1d1111fa56fd7c7a64987c745248181c250c63ebea907ebf1003b03'
)
if [ "$CARCH" = 'pentium4' ]; then
@@ -14,8 +14,6 @@ fi
if [ "$CARCH" = 'i686' ]; then
eval "$(
- declare -f prepare | \
- sed '/cd openal-soft/ a patch -p1 -i \"$srcdir/openal-i686.patch\"'
declare -f build | \
sed '/cmake .*openal-soft/ s/;$/ -DALSOFT_CPUEXT_SSE4_1=0 -DALSOFT_CPUEXT_SSE3=0 -DALSOFT_CPUEXT_SSE2=0;/'
)"
diff --git a/extra/openal/openal-i686.patch b/extra/openal/openal-i686.patch
deleted file mode 100644
index 4a42844d..00000000
--- a/extra/openal/openal-i686.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0cf0613d..53b325db 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -369,20 +369,25 @@ set(HAVE_SSE3 0)
- set(HAVE_SSE4_1 0)
- set(HAVE_NEON 0)
-
--# Check for SSE+SSE2 support
-+# Check for SSE support
- option(ALSOFT_REQUIRE_SSE "Require SSE support" OFF)
--option(ALSOFT_REQUIRE_SSE2 "Require SSE2 support" OFF)
--if(HAVE_XMMINTRIN_H AND HAVE_EMMINTRIN_H)
-+if(HAVE_XMMINTRIN_H)
- option(ALSOFT_CPUEXT_SSE "Enable SSE support" ON)
-- option(ALSOFT_CPUEXT_SSE2 "Enable SSE2 support" ON)
-- if(ALSOFT_CPUEXT_SSE AND ALSOFT_CPUEXT_SSE2)
-+ if(ALSOFT_CPUEXT_SSE)
- set(HAVE_SSE 1)
-- set(HAVE_SSE2 1)
- endif()
- endif()
- if(ALSOFT_REQUIRE_SSE AND NOT HAVE_SSE)
- message(FATAL_ERROR "Failed to enabled required SSE CPU extensions")
- endif()
-+
-+option(ALSOFT_REQUIRE_SSE2 "Require SSE2 support" OFF)
-+if(HAVE_EMMINTRIN_H)
-+ option(ALSOFT_CPUEXT_SSE2 "Enable SSE2 support" ON)
-+ if(HAVE_SSE AND ALSOFT_CPUEXT_SSE2)
-+ set(HAVE_SSE2 1)
-+ endif()
-+endif()
- if(ALSOFT_REQUIRE_SSE2 AND NOT HAVE_SSE2)
- message(FATAL_ERROR "Failed to enable required SSE2 CPU extensions")
- endif()
-@@ -758,9 +763,13 @@ set(ALC_OBJS
-
- # Include SIMD mixers
- set(CPU_EXTS "Default")
-+if(HAVE_SSE)
-+ set(CORE_OBJS ${CORE_OBJS} core/mixer/mixer_sse.cpp)
-+ set(CPU_EXTS "${CPU_EXTS}, SSE")
-+endif()
- if(HAVE_SSE2)
-- set(CORE_OBJS ${CORE_OBJS} core/mixer/mixer_sse.cpp core/mixer/mixer_sse2.cpp)
-- set(CPU_EXTS "${CPU_EXTS}, SSE, SSE2")
-+ set(CORE_OBJS ${CORE_OBJS} core/mixer/mixer_sse2.cpp)
-+ set(CPU_EXTS "${CPU_EXTS}, SSE2")
- endif()
- if(HAVE_SSE3)
- set(CORE_OBJS ${CORE_OBJS} core/mixer/mixer_sse3.cpp)
-diff --git a/core/mixer/mixer_sse.cpp b/core/mixer/mixer_sse.cpp
-index 23caf797..c0fd8fa1 100644
---- a/core/mixer/mixer_sse.cpp
-+++ b/core/mixer/mixer_sse.cpp
-@@ -15,9 +15,8 @@ struct BSincTag;
- struct FastBSincTag;
-
-
--/* SSE2 is required for any SSE support. */
--#if defined(__GNUC__) && !defined(__clang__) && !defined(__SSE2__)
--#pragma GCC target("sse2")
-+#if defined(__GNUC__) && !defined(__clang__) && !defined(__SSE__)
-+#pragma GCC target("sse")
- #endif
-
- namespace {