Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/meson
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-04-07 16:36:05 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-04-07 16:36:05 +0300
commit6f57aec09094858dcf5a7a0088f796cf34aa1458 (patch)
treeecf326cc1518fc39b20f190a812714a31a4fba50 /extra/meson
parent5cbf31812681d0637486bcd69f101f9552bf8b36 (diff)
extra/meson: Update arch-meson
Diffstat (limited to 'extra/meson')
-rw-r--r--extra/meson/PKGBUILD4
-rwxr-xr-xextra/meson/arch-meson1
2 files changed, 3 insertions, 2 deletions
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index b3fe95a2..5e49a967 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -21,7 +21,7 @@ unset checkdepends
# we patch a version of arch-meson reading CARCH (later maybe LTOFLAGS)
# to find out whether it should add blto to the arch flags
for ((i=0; i<${#b2sums[@]}; i++)); do
- if [ "${b2sums[${i}]}" = '801ad7689aabd2861c760d6001ce2e84c3d5aaed867b087bc1699e7c15d914ee26c9d855999f389d28b4765f081523a1468755768bc0163185f132e157ecced1' ]; then
- b2sums[${i}]='9f134aabfce63ed31e579724cdfb6de0a8a4c27998a11caa796c7660842904d646688e6f106026f9a68f4c67ea7a61d7d86c762e4688db0f383268a85880edf8'
+ if [ "${b2sums[${i}]}" = '70f042a7603d1139f6cef33aec028da087cacabe278fd47375e1b2315befbfde1c0501ad1ecc63d04d31b232a04f08c735d61ce59d7244521f3d270e417fb5af' ]; then
+ b2sums[${i}]='09f3035aaff3fe8ac8e57a6e718acd654c04604500abb897a4d6e3946c9e4d9db6a257b5cd3d27007bfcfd4799a2b52d8eaab38ecda16f8af69848ed3b8ac7ff'
fi
done
diff --git a/extra/meson/arch-meson b/extra/meson/arch-meson
index 577edca4..fac70e6a 100755
--- a/extra/meson/arch-meson
+++ b/extra/meson/arch-meson
@@ -18,4 +18,5 @@ exec meson setup \
--wrap-mode nodownload \
-D "${LTO}" \
-D b_pie=true \
+ -D python.bytecompile=1 \
"$@"