Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/llvm
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-27 20:00:39 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-27 20:00:39 +0200
commitb265ff7afab5cdbd449d1f440e7e0e95105f2143 (patch)
treeee462847e09d6c61f1f5b10bd5a408269158ab8b /extra/llvm
parent913e651aec1bc026cd1fba641d8cf0a9bbf7dbda (diff)
extra/llvm: no OCAML temporarily
Diffstat (limited to 'extra/llvm')
-rw-r--r--extra/llvm/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/llvm/PKGBUILD b/extra/llvm/PKGBUILD
new file mode 100644
index 00000000..4aaafe29
--- /dev/null
+++ b/extra/llvm/PKGBUILD
@@ -0,0 +1,19 @@
+# temporary, ocaml is broken on 32-bit, we work around the llvm issue
+# in binutils LTO plugins for now:
+makedepends=(${makedepends[@]/ocaml=$_ocaml_ver/})
+makedepends=(${makedepends[@]/ocaml-ctypes/})
+makedepends=(${makedepends[@]/ocaml-findlib/})
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/ninja all ocaml_doc/ninja all/
+ '
+)"
+
+eval "$(
+ declare -f package_llvm | \
+ sed '
+ /ocaml/d
+ '
+)"