Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/llvm
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-12-05 17:35:55 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2018-12-05 17:35:55 +0100
commit665c195f3812e8a410095ac2ffa5a692116870e2 (patch)
tree3ca1f64ad3bd0a120b8defc400327edcd3cfe9b9 /extra/llvm
parent4ede4b823d1d8bc943b0cafeb2c9459668f70eb2 (diff)
extra/llvm: trying to break the ocaml circle
Diffstat (limited to 'extra/llvm')
-rw-r--r--extra/llvm/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/llvm/PKGBUILD b/extra/llvm/PKGBUILD
new file mode 100644
index 00000000..4aaafe29
--- /dev/null
+++ b/extra/llvm/PKGBUILD
@@ -0,0 +1,19 @@
+# temporary, ocaml is broken on 32-bit, we work around the llvm issue
+# in binutils LTO plugins for now:
+makedepends=(${makedepends[@]/ocaml=$_ocaml_ver/})
+makedepends=(${makedepends[@]/ocaml-ctypes/})
+makedepends=(${makedepends[@]/ocaml-findlib/})
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/ninja all ocaml_doc/ninja all/
+ '
+)"
+
+eval "$(
+ declare -f package_llvm | \
+ sed '
+ /ocaml/d
+ '
+)"