Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libuv
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-07 16:02:30 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-07 16:02:30 +0000
commite924f3306d441315a28edca245a62be18bb7b454 (patch)
tree740116ae5bcc6d699fbc62867d5de5d0efba7f15 /extra/libuv
parente13625b5702b0d2f7abfbdc028834f1218b4b13b (diff)
extra/libuv: added i486 specific patches
Diffstat (limited to 'extra/libuv')
-rw-r--r--extra/libuv/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/libuv/PKGBUILD b/extra/libuv/PKGBUILD
index e69de29b..39ff340b 100644
--- a/extra/libuv/PKGBUILD
+++ b/extra/libuv/PKGBUILD
@@ -0,0 +1,17 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no python sphinx
+ makedepends=(${makedepends[@]//python-sphinx/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /make man/d
+ '
+ declare -f package | \
+ sed '
+ /install.*libuv/d
+ '
+ )"
+fi
+
+