Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libcroco
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2024-09-23 21:23:06 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2024-09-23 21:23:06 +0200
commitcc3fe78f72441197f9f72e1571fb6591d2eb4c7e (patch)
tree3bd8e65a50dcdc789d1f61d0e5c750129a7ddb33 /extra/libcroco
parent3eb8cfe3e219ebc9cc6a72907166f736b5f32d44 (diff)
extra/libcroco: added from the AUR
Diffstat (limited to 'extra/libcroco')
-rw-r--r--extra/libcroco/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/extra/libcroco/PKGBUILD b/extra/libcroco/PKGBUILD
new file mode 100644
index 00000000..dfe274e5
--- /dev/null
+++ b/extra/libcroco/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libcroco
+pkgver=0.6.13
+pkgrel=2
+pkgdesc="A CSS parsing library"
+url="https://gitlab.gnome.org/GNOME/libcroco"
+arch=(x86_64)
+depends=(glib2 libxml2)
+makedepends=(intltool git gtk-doc)
+license=(LGPL)
+_commit=7e15ca6c2c29a4b78367e6efa6195b331a92b2a7 # tags/0.6.13^0
+source=("git+https://gitlab.gnome.org/GNOME/libcroco.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+check() {
+ cd $pkgname
+ make check
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr --disable-static --enable-gtk-doc
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}