Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/ksh/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
committerErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
commite74cde76c104df82b120a7b13964cb786da8f565 (patch)
tree39967e24037929c04aaf79922aa260b437a60a5e /extra/ksh/PKGBUILD
parent73e1d3b448cc583ab38cae4d61a26f313fad946b (diff)
community -> extra
Diffstat (limited to 'extra/ksh/PKGBUILD')
-rw-r--r--extra/ksh/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/ksh/PKGBUILD b/extra/ksh/PKGBUILD
new file mode 100644
index 00000000..984eb7ba
--- /dev/null
+++ b/extra/ksh/PKGBUILD
@@ -0,0 +1,9 @@
+# on i486, uname reports the wrong architecture, so tests fail
+if [ "${CARCH}" = 'i486' ]; then
+ eval "$(
+ declare -f check \
+ | sed '
+ /meson test/ s@$@ || true; ! grep -vwF uname meson-logs/testlog.txt | grep -qwF FAIL@
+ '
+ )"
+fi