Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/ispc/ispc-1.16.1-host-amd64.patch
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
committerErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
commite74cde76c104df82b120a7b13964cb786da8f565 (patch)
tree39967e24037929c04aaf79922aa260b437a60a5e /extra/ispc/ispc-1.16.1-host-amd64.patch
parent73e1d3b448cc583ab38cae4d61a26f313fad946b (diff)
community -> extra
Diffstat (limited to 'extra/ispc/ispc-1.16.1-host-amd64.patch')
-rw-r--r--extra/ispc/ispc-1.16.1-host-amd64.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/extra/ispc/ispc-1.16.1-host-amd64.patch b/extra/ispc/ispc-1.16.1-host-amd64.patch
new file mode 100644
index 00000000..78ef5f20
--- /dev/null
+++ b/extra/ispc/ispc-1.16.1-host-amd64.patch
@@ -0,0 +1,16 @@
+diff -rauN ispc-1.16.1/CMakeLists.txt ispc-1.16.1-host-amd64-patch/CMakeLists.txt
+--- ispc-1.16.1/CMakeLists.txt 2021-07-16 01:04:31.000000000 +0200
++++ ispc-1.16.1-host-amd64-patch/CMakeLists.txt 2022-04-07 08:57:32.100539305 +0200
+@@ -45,9 +45,9 @@
+ project(${PROJECT_NAME})
+
+ set(X86_HOST FALSE)
+-if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
+- set(X86_HOST TRUE)
+-endif()
++#if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
++# set(X86_HOST TRUE)
++#endif()
+
+ option(X86_ENABLED "Enable x86 support" ${X86_HOST})
+ option(ARM_ENABLED "Enable ARM support" ON)