Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/gegl
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-01-16 15:03:18 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-01-16 15:03:18 +0100
commit785e11ce29c34a9924bd7c152557de366480d055 (patch)
tree1d6a290e5564eb98566743d6fae4af299e8885ca /extra/gegl
parenta189b54dda8dd8fd9a127540a3a1e8fc10671c57 (diff)
extra/gegl: no vala API on i486
Diffstat (limited to 'extra/gegl')
-rw-r--r--extra/gegl/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/extra/gegl/PKGBUILD b/extra/gegl/PKGBUILD
new file mode 100644
index 00000000..08592578
--- /dev/null
+++ b/extra/gegl/PKGBUILD
@@ -0,0 +1,21 @@
+# no Vala on i486
+makedepends=(${makedepends[@]//vala/})
+makedepends_i686+=(vala)
+makedepends_pentium4=("${makedepends_i686[@]}")
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no Gnome (gjs), no dbus-glib
+ unset check
+
+ # disable Vala (not bootstrapped for i486)
+ eval "$(
+ declare -f build | \
+ sed '
+ s/\(arch-meson .* \)/\1 -Dvapi=false /
+ '
+ )"
+fi
+
+# python-gobject
+# ffmpeg