Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-15 07:18:08 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-15 07:18:08 +0200
commit4ffb3d28454e8f8f808418e3adb8509d3efc220e (patch)
treecf96947c91cd97e4da8ede3107cd1eb8afcb6358 /extra/firefox
parent173657e4057b9af336f032b304199ab094eaacd7 (diff)
extra/firefox: use 14.0.6 and not 14.0.6-1.0 as wasi dependency version
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 97580b1f..5cc4e992 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -22,9 +22,9 @@ eval "$(
'
)"
fi
-makedepends=("${makedepends[@]/wasi-compiler-rt/wasi-compiler-rt=14.0.6-1.0}") # dustbin
+makedepends=("${makedepends[@]/wasi-compiler-rt/wasi-compiler-rt=14.0.6}") # dustbin
makedepends=(${makedepends[*]/wasi-libc++*/})
-makedepends+=(wasi-libc++=14.0.6-1.0 wasi-libc++abi=14.0.6-1.0 llvm13) # dustbin
+makedepends+=(wasi-libc++=14.0.6 wasi-libc++abi=14.0.6 llvm13) # dustbin
# try hard to tell ld and rust not to use too much memory (no lto, no debug info, etc.)
eval "$(
@@ -200,12 +200,12 @@ fi
# https://bugzilla.mozilla.org/show_bug.cgi?id=1710235
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100644
#
-#11:28.22 /usr/include/c++/11.1.0/type_traits:2933:11: error: no type named ‘type’ in
-# ‘struct std::invoke_result<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<m
+#11:28.22 /usr/include/c++/11.1.0/type_traits:2933:11: error: no type named ?type? in
+# ?struct std::invoke_result<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<m
#ozilla::dom::AccessibleNode> > >::PutEntry(nsTHashtable<nsBaseHashtableET<nsUint32Ha
#shKey, RefPtr<mozilla::dom::AccessibleNode> > >::KeyType, const fallible_t&)::<lambd
#a(auto:7)>, mozilla::Maybe<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<mo
-#zilla::dom::AccessibleNode> > >::EntryHandle>&&>’
+#zilla::dom::AccessibleNode> > >::EntryHandle>&&>?
#11:28.22 2933 | using invoke_result_t = typename invoke_result<_Fn, _Args...>::
#type;
makedepends+=(gcc10)
@@ -228,7 +228,7 @@ eval "$(
)"
# 214:49.30 /build/firefox/src/firefox-99.0.1/modules/fdlibm/src/math_private.h:34:21: error: conflicting
-# declaration ‘typedef __double_t double_t’
+# declaration ?typedef __double_t double_t?
source+=('firefox-99.0.1-fdlibm-double.patch')
sha256sums+=('62695e56daf8c0b8bb921980d475b3fd169b9134188ad9ffaeb9cd660589c23d')
eval "$(