Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-25 07:25:52 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-25 07:25:52 +0200
commit437b67e3e6dc91f7c2bec294c64f6b9402221356 (patch)
treec74f33274b9539a2ad2b76273fd39727f40ef7e2 /extra/firefox
parent27e0f91bae59415b7f35ad9a88cd90bb421838c5 (diff)
extra/firefox: added fix-i686-build-moz-1792159 from VoidLinux
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD11
-rw-r--r--extra/firefox/fix-i686-build-moz-1792159.patch18
2 files changed, 28 insertions, 1 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 5d98c763..eec4248a 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -211,7 +211,7 @@ eval "$(
# declaration ?typedef __double_t double_t?
# and
# typedef __float_t float_t;
-# /usr/include/math.h:169:21: note: previous declaration as ?typedef long double float_t?
+# /usr/include/math.h:169:21: note: previous declaration as ‘typedef long double float_t’
# typedef long double float_t;
source+=('firefox-106.0.1-fdlibm.patch')
sha256sums+=('ddc0945f2414828668dd922b6b8203f7fb54d7b1f0aac3e18299bccb5c2facab')
@@ -243,3 +243,12 @@ eval "$(
'
)"
+# from Voidlinux, enable atomics in JIT for i686
+source+=('fix-i686-build-moz-1792159.patch')
+sha256sums+=('2fb39374fd3d80eea9e346032a2a4b2bc2e357dee7380855b24bcf19b1335d06')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/fix-i686-build-moz-1792159.patch"
+ '
+)"
diff --git a/extra/firefox/fix-i686-build-moz-1792159.patch b/extra/firefox/fix-i686-build-moz-1792159.patch
new file mode 100644
index 00000000..592dcad9
--- /dev/null
+++ b/extra/firefox/fix-i686-build-moz-1792159.patch
@@ -0,0 +1,18 @@
+--- a/js/src/jit/shared/AtomicOperations-shared-jit.cpp
++++ b/js/src/jit/shared/AtomicOperations-shared-jit.cpp
+@@ -5,4 +5,9 @@
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
++// bug 1792159
++#if defined(__i386__) && defined(__GNUC__) && !defined(__clang__)
++# include "../../../mfbt/Attributes.h"
++#endif
++
+ #include "jit/AtomicOperations.h"
+
+--- a/config/check_spidermonkey_style.py
++++ b/config/check_spidermonkey_style.py
+@@ -68,2 +68,3 @@
+ "jit/AtomicOperationsGenerated.h", # generated in $OBJDIR
++ "../../../mfbt/Attributes.h", # unrecognized path
+ "jit/CacheIROpsGenerated.h", # generated in $OBJDIR