Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-26 18:44:46 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-26 18:44:46 +0200
commit42ec7e1bed416c9fac5986659e80ec6d901ec5ac (patch)
tree659f9aaa4cc8a5aa9a4553df11ad2481814d1c76 /extra/firefox
parentd34b352518a3d2cd31b00df4e6e11670bf7e69c2 (diff)
extra/firefox: trying to build 104.0.2
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD30
-rw-r--r--extra/firefox/mozconfig-i686.patch8
-rw-r--r--extra/firefox/mozconfig-pentium4.patch8
3 files changed, 10 insertions, 36 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 316038d3..62882c10 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -4,7 +4,7 @@
# set correct compiler and toochain tools
if [ "${CARCH}" = "pentium4" ]; then
source+=('mozconfig-pentium4.patch')
- sha256sums+=('6aafff15bc3e11137a295869c16bf07aaf110f5fa39545bb27da1a182d1e9b4a')
+ sha256sums+=('e0d62cbed819264cb000a73260201c357a72ce0abcf9eaede3588f270a566f9a')
eval "$(
declare -f prepare | \
sed '
@@ -14,7 +14,7 @@ eval "$(
fi
if [ "${CARCH}" = "i686" ]; then
source+=('mozconfig-i686.patch')
- sha256sums+=('56f7faa75bc16b9948c37e84309efd59c7d932a6f9a579135040fa7f94da35db')
+ sha256sums+=('9cdfa0d20ffaf1102b16e4cf97add8819939647316e4c7d65d642e2a7cea1ad0')
eval "$(
declare -f prepare | \
sed '
@@ -22,9 +22,6 @@ eval "$(
'
)"
fi
-makedepends=("${makedepends[@]/wasi-compiler-rt/wasi-compiler-rt=14.0.6}") # dustbin
-makedepends=(${makedepends[*]/wasi-libc++*/})
-makedepends+=(wasi-libc++=14.0.6 wasi-libc++abi=14.0.6 llvm13) # dustbin
# try hard to tell ld and rust not to use too much memory (no lto, no debug info, etc.)
eval "$(
@@ -193,23 +190,6 @@ if [ "${CARCH}" = "i686" ]; then
CXXFLAGS="$CXXFLAGS -mmmx"
fi
-# actually, this should be fixed in gcc 11?
-# for now let's build with gcc10
-#
-# https://bugzilla.mozilla.org/show_bug.cgi?id=1713071
-# https://bugzilla.mozilla.org/show_bug.cgi?id=1710235
-# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100644
-#
-#11:28.22 /usr/include/c++/11.1.0/type_traits:2933:11: error: no type named ?type? in
-# ?struct std::invoke_result<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<m
-#ozilla::dom::AccessibleNode> > >::PutEntry(nsTHashtable<nsBaseHashtableET<nsUint32Ha
-#shKey, RefPtr<mozilla::dom::AccessibleNode> > >::KeyType, const fallible_t&)::<lambd
-#a(auto:7)>, mozilla::Maybe<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<mo
-#zilla::dom::AccessibleNode> > >::EntryHandle>&&>?
-#11:28.22 2933 | using invoke_result_t = typename invoke_result<_Fn, _Args...>::
-#type;
-makedepends+=(gcc10)
-
# do not build and phone back symbols, fails anyway with:
# "panic occurred at library/alloc/src/raw_vec.rs:537: capacity overflow\n" in
# dump_syms (see also FS32#174)
@@ -248,3 +228,9 @@ eval "$(
strip "$pkgdir/usr/lib/$pkgname/libxul.so"
'
)"
+
+# 105.0.x has issues with AVX2 creeping everywhere, let's build 104 for now (and hope they fix it)
+sed -i '
+ s/^pkgver=105.0.1$/pkgver=104.0.2/
+' PKGBUILD
+sha256sums[0]='72bba06f04e7745f6b02951906413eb1c15a7e253e06e373302162c6219f286a'
diff --git a/extra/firefox/mozconfig-i686.patch b/extra/firefox/mozconfig-i686.patch
index f4d3c077..35b0a095 100644
--- a/extra/firefox/mozconfig-i686.patch
+++ b/extra/firefox/mozconfig-i686.patch
@@ -12,7 +12,7 @@ diff -rauN a/mozconfig b/mozconfig
ac_add_options --disable-elf-hack
# Branding
-@@ -35,3 +35,11 @@
+@@ -35,3 +35,5 @@
ac_add_options --enable-crashreporter
ac_add_options --disable-updater
ac_add_options --disable-tests
@@ -20,9 +20,3 @@ diff -rauN a/mozconfig b/mozconfig
+# pentium4 specific options
+ac_add_options --disable-lto
+ac_add_options --disable-install-strip
-+export CC=gcc-10
-+export CXX=g++-10
-+export AR=gcc-ar-10
-+export NM=gcc-nm-10
-+export RANLIB=gcc-ranlib-10
-+export STRIP=strip
diff --git a/extra/firefox/mozconfig-pentium4.patch b/extra/firefox/mozconfig-pentium4.patch
index 0201a74f..1cecd845 100644
--- a/extra/firefox/mozconfig-pentium4.patch
+++ b/extra/firefox/mozconfig-pentium4.patch
@@ -10,7 +10,7 @@ diff -rauN a/mozconfig b/mozconfig
ac_add_options --disable-elf-hack
# Branding
-@@ -35,3 +35,11 @@
+@@ -35,3 +35,5 @@
ac_add_options --enable-crashreporter
ac_add_options --disable-updater
ac_add_options --disable-tests
@@ -18,9 +18,3 @@ diff -rauN a/mozconfig b/mozconfig
+# pentium4 specific options
+ac_add_options --disable-lto
+ac_add_options --disable-install-strip
-+export CC=gcc-10
-+export CXX=g++-10
-+export AR=gcc-ar-10
-+export NM=gcc-nm-10
-+export RANLIB=gcc-ranlib-10
-+export STRIP=strip