Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-21 14:22:24 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-21 14:22:24 +0200
commit92f59742b9850db7f9be4c1c5fe18946cc045413 (patch)
tree5aa26c65e5d3bbbe1862982bd69095100ff3b6fa /extra/firefox/PKGBUILD
parent3c0b71074edc1d7a30d78fb48cdfcae6192abca7 (diff)
extra/firefox: do not execute breaking rust tests
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 8ee63332..46db9912 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -87,3 +87,14 @@ eval "$(
2 a export MOZ_MAKE_FLAGS=-j1
'
)"
+
+# test failure in rust code (complaining about network functions) when PGO is used,
+# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
+source+=('rust-static-disable-network-test-on-static-libraries.patch')
+sha256sums+=('3502138d1b43d734743137b97ea220d56338e7ee15d6159b030489637e274fc0')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/rust-static-disable-network-test-on-static-libraries.patch"
+ '
+)"