Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/chromium
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-03-09 19:41:11 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2019-03-09 19:41:11 +0100
commitdffdb1c724b4c4916626560d729f8fc3790fc193 (patch)
tree2c0ce3eafc2f3fd0b11437a9d45836c44e6591aa /extra/chromium
parentcd80c8f39d64bb3d5d392a048f1d44fe94177394 (diff)
extra/chromium: repatch uintptr in vaapi
Diffstat (limited to 'extra/chromium')
-rw-r--r--extra/chromium/PKGBUILD4
-rw-r--r--extra/chromium/chromium-vaapi-uintptr.patch22
2 files changed, 2 insertions, 24 deletions
diff --git a/extra/chromium/PKGBUILD b/extra/chromium/PKGBUILD
index 89997a42..3bbadf17 100644
--- a/extra/chromium/PKGBUILD
+++ b/extra/chromium/PKGBUILD
@@ -8,11 +8,11 @@ declare -f build | \
# fix regression uintptr_t in vaapi
source+=(chromium-vaapi-uintptr.patch)
-sha256sums+=('67e4eccc8134fc422f86cc1f1371b84be11f6f84ec5f041ea6178e304f0fe995')
+sha256sums+=('c1b2285dec2acae6108a496cba9230680cd5eedf3467d4563ec4b546fc8224aa')
eval "$(
declare -f prepare | \
sed '
- /chromium-vaapi.patch/i patch -Np1 -i ../chromium-vaapi-uintptr.patch
+ /chromium-vaapi-fix-the/a patch -Np1 -i ../chromium-vaapi-uintptr.patch
'
)"
diff --git a/extra/chromium/chromium-vaapi-uintptr.patch b/extra/chromium/chromium-vaapi-uintptr.patch
index c64414a8..a2405071 100644
--- a/extra/chromium/chromium-vaapi-uintptr.patch
+++ b/extra/chromium/chromium-vaapi-uintptr.patch
@@ -9,28 +9,6 @@ diff -rauN chromium-72.0.3626.121/media/gpu/vaapi/vaapi_wrapper.cc chromium-72.0
#include <dlfcn.h>
#include <string.h>
-@@ -333,10 +334,17 @@
- DVLOG(1) << "VAAPI version: " << major_version << "." << minor_version << " "
- << va_vendor_string_;
-
-- if (major_version != VA_MAJOR_VERSION || minor_version != VA_MINOR_VERSION) {
-- LOG(ERROR) << "This build of Chromium requires VA-API version "
-- << VA_MAJOR_VERSION << "." << VA_MINOR_VERSION
-- << ", system version: " << major_version << "." << minor_version;
-+ // The VAAPI version is determined from what is loaded on the system by
-+ // calling vaInitialize(). Since the libva is now ABI-compatible, relax the
-+ // version check which helps in upgrading the libva, without breaking any
-+ // existing functionality. Make sure the system version is not older than
-+ // the version with which the chromium is built since libva is only
-+ // guaranteed to be backward (and not forward) compatible.
-+ if (VA_MAJOR_VERSION > major_version ||
-+ (VA_MAJOR_VERSION == major_version && VA_MINOR_VERSION > minor_version)) {
-+ LOG(ERROR) << "The system version " << major_version << "." << minor_version
-+ << " should be greater than or equal to "
-+ << VA_MAJOR_VERSION << "." << VA_MINOR_VERSION;
- return false;
- }
- return true;
@@ -1000,7 +1008,7 @@
}
va_attrib_extbuf.num_planes = num_planes;