Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/chromium
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-03-10 10:15:01 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-03-10 10:15:01 +0100
commit15e2e1894dbdfd282dccbb0ae67e50ec808a60ee (patch)
treebc8b2d2f054898fdbb2b3e83c69b53bb966b36bd /extra/chromium
parentcbf98df66964463ec7ce0a0d80930abf53299eb0 (diff)
extra/chromium: redone patch sedfu
Diffstat (limited to 'extra/chromium')
-rw-r--r--extra/chromium/PKGBUILD15
-rw-r--r--extra/chromium/chromium-vaapi-uintptr.patch20
2 files changed, 2 insertions, 33 deletions
diff --git a/extra/chromium/PKGBUILD b/extra/chromium/PKGBUILD
index 69e59c86..d0d51af5 100644
--- a/extra/chromium/PKGBUILD
+++ b/extra/chromium/PKGBUILD
@@ -6,17 +6,6 @@ declare -f build | \
'
)"
-# fix regression uintptr_t in vaapi
-source+=(chromium-vaapi-uintptr.patch)
-sha256sums+=('c1b2285dec2acae6108a496cba9230680cd5eedf3467d4563ec4b546fc8224aa')
-
-eval "$(
- declare -f prepare | \
- sed '
- /chromium-vaapi-fix-the/a patch -Np1 -i ../chromium-vaapi-uintptr.patch
- '
-)"
-
# no SAMUFLAGS, see https://www.mail-archive.com/pacman-dev@archlinux.org/msg17258.html
# going the sed-way
eval "$(
@@ -57,7 +46,7 @@ fi
#eval "$(
# declare -f prepare | \
# sed '
-# /patch.*chromium-106.*/a patch -Np1 -i "$srcdir/chromium-81.0.4044.122-Fix-sandbox-Aw-snap-for-syscalls-403-and-407.patch"
+# /cd chromium-$pkgver/a patch -Np1 -i "$srcdir/chromium-81.0.4044.122-Fix-sandbox-Aw-snap-for-syscalls-403-and-407.patch"
# '
#)"
@@ -67,6 +56,6 @@ sha256sums+=('f3d3702106e2307c00f1db97fa2614bbedd208ecb217052e3cc789945e17a139')
eval "$(
declare -f prepare | \
sed '
- /patch.*chromium-106.*/a patch -Np1 -i "$srcdir/reenable-linux-i686-builds.patch"
+ /cd chromium-$pkgver/a patch -Np1 -i "$srcdir/reenable-linux-i686-builds.patch"
'
)"
diff --git a/extra/chromium/chromium-vaapi-uintptr.patch b/extra/chromium/chromium-vaapi-uintptr.patch
deleted file mode 100644
index a2405071..00000000
--- a/extra/chromium/chromium-vaapi-uintptr.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -rauN chromium-72.0.3626.121/media/gpu/vaapi/vaapi_wrapper.cc chromium-72.0.3626.121-vaapi-uintptr-patch/media/gpu/vaapi/vaapi_wrapper.cc
---- chromium-72.0.3626.121/media/gpu/vaapi/vaapi_wrapper.cc 2019-03-02 05:10:25.000000000 +0100
-+++ chromium-72.0.3626.121-vaapi-uintptr-patch/media/gpu/vaapi/vaapi_wrapper.cc 2019-03-09 19:02:37.795731310 +0100
-@@ -4,6 +4,7 @@
-
- #include "media/gpu/vaapi/vaapi_wrapper.h"
-
-+#include <cstdint>
- #include <dlfcn.h>
- #include <string.h>
-
-@@ -1000,7 +1008,7 @@
- }
- va_attrib_extbuf.num_planes = num_planes;
-
-- std::vector<unsigned long> fds(num_fds);
-+ std::vector<uintptr_t> fds(num_fds);
- for (size_t i = 0; i < num_fds; ++i) {
- int dmabuf_fd = pixmap->GetDmaBufFd(i);
- if (dmabuf_fd < 0) {