Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/boost
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-06-16 16:30:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-06-16 16:30:58 +0200
commit23db8c4956e6e903970d23891b1c0d6d2995ebdd (patch)
tree10b673cd725a5b301fb312124cca2f16a2df44c1 /extra/boost
parent561d6372fdb19de1164d40463258650cba6a4593 (diff)
extra/boost: disabling LTO on i486
Diffstat (limited to 'extra/boost')
-rw-r--r--extra/boost/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/boost/PKGBUILD b/extra/boost/PKGBUILD
new file mode 100644
index 00000000..12fb68df
--- /dev/null
+++ b/extra/boost/PKGBUILD
@@ -0,0 +1,14 @@
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-ffat-lto-objects//g
+ '
+ )"
+fi