Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/apr
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-08-18 10:32:14 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-08-18 10:32:14 +0200
commitacf7fbc1e59b1c0f35960af8bcb9c3edbc702cab (patch)
treeae74b96dc6a7e0f474ef9ed66a544cc2fd11f651 /extra/apr
parent36ce3e2f5f0c0aaac484df9cb87cbe0ef0e134f7 (diff)
extra/apr: fixed download location and uint64 probing
Diffstat (limited to 'extra/apr')
-rw-r--r--extra/apr/PKGBUILD30
-rw-r--r--extra/apr/apr-1.7.0-no-explicit-confdefs-uint64-probing.patch15
2 files changed, 44 insertions, 1 deletions
diff --git a/extra/apr/PKGBUILD b/extra/apr/PKGBUILD
index f11a97b8..6f7149dc 100644
--- a/extra/apr/PKGBUILD
+++ b/extra/apr/PKGBUILD
@@ -1,4 +1,32 @@
-# disable compiler atomics on u486
+# download location broken (FS#75636)
+source[0]="https://dlcdn.apache.org/apr/apr-$pkgver.tar.bz2"
+source[1]="https://dlcdn.apache.org/apr/apr-$pkgver.tar.bz2.asc"
+
+# uint64_t probing broken, see
+# https://github.com/apache/apr/pull/25
+# https://github.com/apache/apr/commit/0a763c5e500f4304b7c534fae0fad430d64982e8?diff=unified
+source+=('apr-1.7.0-no-explicit-confdefs-uint64-probing.patch')
+sha256sums+=('bac28c5519081e3854a11e97ff4493719a98c140b17d9980f8ea8380cbb9bfa3')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd "${pkgname}-${pkgver}"\n}\n'
+ } \
+ | sed '
+ /buildconf/ i patch -Rp1 -i "../apr-1.7.0-no-explicit-confdefs-uint64-probing.patch"
+ '
+)"
+
+# i486-specific, missing atomics
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure |LDFLAGS="-latomic" ./configure |g
+ ';
+ )"
+fi
+
if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
diff --git a/extra/apr/apr-1.7.0-no-explicit-confdefs-uint64-probing.patch b/extra/apr/apr-1.7.0-no-explicit-confdefs-uint64-probing.patch
new file mode 100644
index 00000000..a50e9fed
--- /dev/null
+++ b/extra/apr/apr-1.7.0-no-explicit-confdefs-uint64-probing.patch
@@ -0,0 +1,15 @@
+diff -rauN apr-1.7.0/build/apr_common.m4 apr-1.7.0-no-explicit-confdefs-uint64-probing-patch/build/apr_common.m4
+--- apr-1.7.0/build/apr_common.m4 2022-08-18 09:25:07.178587001 +0200
++++ apr-1.7.0-no-explicit-confdefs-uint64-probing-patch/build/apr_common.m4 2022-08-18 09:19:29.618091904 +0200
+@@ -505,10 +505,7 @@
+ fi
+ AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE(
+- [
+-#ifndef PACKAGE_NAME
+-#include "confdefs.h"
+-#endif
++ [#include "confdefs.h"
+ ]
+ [[$1]]
+ [int main(int argc, const char *const *argv) {]