Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-02-27 14:07:56 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2020-02-27 14:07:56 +0100
commitde70c7f415b7b7d88d8b5d19b5c9abbfc2226bcc (patch)
treea6f91833bb3e0c65de634777ad81a3c1b7789282 /core
parentf33aa847e1d9a8573ab9963a07316b891270428c (diff)
core/libseccomp: removed local patching, 2.4.2 is available from upstream
Diffstat (limited to 'core')
-rw-r--r--core/libseccomp/PKGBUILD64
-rw-r--r--core/libseccomp/libseccomp-2.4.2-ppoll.patch25
2 files changed, 0 insertions, 89 deletions
diff --git a/core/libseccomp/PKGBUILD b/core/libseccomp/PKGBUILD
deleted file mode 100644
index 99ccab09..00000000
--- a/core/libseccomp/PKGBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-#valgrind: fatal error: unsupported CPU.
-# Supported CPUs are:
-# * x86 (practically any; Pentium-I or above), AMD Athlon or above)
-# * AMD Athlon64/Opteron
-# * ARM (armv7)
-# * MIPS (mips32 and above; mips64 and above)
-# * PowerPC (most; ppc405 and above)
-# * System z (64bit only - s390x; z990 and above)
-# Test 49-sim-64b_comparisons%%011-00001 result: FAILURE 49-sim-64b_comparisons rc=1
-#
-# On i486 we have to ignore valgrind tests, as we don't have i486 support
-# for valgrind for now
-if [ "${CARCH}" = "i486" ]; then
- eval "$(
- declare -f check | \
- sed '
- s/make check/make check || true/
- '
- )"
-fi
-
-if [ "${pkgver}" = '2.4.1' ]; then
-
- # force 2.4.2 version as 2.4.1-4 version to make glibc 2.31 work and
- # make it possible to do proper upgrades afterwards to 2.4.2-1
- source=(https://github.com/seccomp/${pkgname}/releases/download/v2.4.2/${pkgname}-2.4.2.tar.gz)
- pkgrel=4
- sha256sums=(b54f27b53884caacc932e75e6b44304ac83586e2abe7a83eca6daecc5440585b)
-
- eval "$(
- declare -f build | \
- sed '
- s/cd ${pkgname}-${pkgver}/cd libseccomp-2.4.2/
- '
- )"
-
- eval "$(
- declare -f check | \
- sed '
- s/cd ${pkgname}-${pkgver}/cd libseccomp-2.4.2/
- '
- )"
-
- eval "$(
- declare -f package | \
- sed '
- s/cd ${pkgname}-${pkgver}/cd libseccomp-2.4.2/
- '
- )"
-
- source+=('libseccomp-2.4.2-ppoll.patch')
- sha256sums+=('2d6f638428bc7f9931d4e0a59b80f13327d6c3748e7049eba54b0be08f6620a9')
- prepare() {
- cd ${pkgbase}-2.4.2
- patch -Np1 -i "$srcdir/libseccomp-2.4.2-ppoll.patch"
- }
-
- # XXX: do NOT trust this key as its not yet in the strong set, see linked issue
- # XXX: https://github.com/seccomp/libseccomp/issues/187
-
- # XXX: 47A68FCE37C7D7024FD65E11356CE62C2B524099 Tom Hromatka <tom.hromatka@oracle.com>
- # XXX: do NOT trust ^^ this key as its not yet in the strong set ^^ see linked issue
- validpgpkeys=('7100AADFAE6E6E940D2E0AD655E45A5AE8CA7C8A') # Paul Moore <paul@paul-moore.com>
-fi
diff --git a/core/libseccomp/libseccomp-2.4.2-ppoll.patch b/core/libseccomp/libseccomp-2.4.2-ppoll.patch
deleted file mode 100644
index 884afb8a..00000000
--- a/core/libseccomp/libseccomp-2.4.2-ppoll.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/include/seccomp-syscalls.h b/include/seccomp-syscalls.h
-index 6457592..3c958df 100644
---- a/include/seccomp-syscalls.h
-+++ b/include/seccomp-syscalls.h
-@@ -272,6 +272,7 @@
- #define __PNR_timerfd_gettime64 -10238
- #define __PNR_timerfd_settime64 -10239
- #define __PNR_utimensat_time64 -10240
-+#define __PNR_ppoll -10241
-
- /*
- * libseccomp syscall definitions
-@@ -1359,6 +1360,12 @@
- #define __SNR_poll __PNR_poll
- #endif
-
-+#ifdef __NR_ppoll
-+#define __SNR_ppoll __NR_ppoll
-+#else
-+#define __SNR_ppoll __PNR_ppoll
-+#endif
-+
- #ifdef __NR_ppoll_time64
- #define __SNR_ppoll_time64 __NR_ppoll_time64
- #else