Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2024-04-26 08:28:25 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2024-04-26 08:28:25 +0200
commit6124fcf88fc07628fdb979f5eee2670b130989fd (patch)
tree4063c2767195a1561f67eab26e993d24b96d8123 /core
parent3605dd7b6515c9156c4ade7950c8be46a17595e3 (diff)
core/coreutils: redone i486 uname patch
Diffstat (limited to 'core')
-rw-r--r--core/coreutils/PKGBUILD4
-rw-r--r--core/coreutils/coreutils-8.30-uname-i486.patch12
-rw-r--r--core/coreutils/coreutils-9.5-uname-i486.patch12
3 files changed, 14 insertions, 14 deletions
diff --git a/core/coreutils/PKGBUILD b/core/coreutils/PKGBUILD
index f4b69568..20eef67e 100644
--- a/core/coreutils/PKGBUILD
+++ b/core/coreutils/PKGBUILD
@@ -1,8 +1,8 @@
# 486-specific
if [ "${CARCH}" = "i486" ]; then
# make uname return i486 instead of i686 when used with setarch
- source+=('coreutils-8.30-uname-i486.patch')
- sha256sums+=('4e3971d7c5f6363d2d2ceeea23958ec6db1d6e5d2c7fc20bc5d6d6bfa7290ad0')
+ source+=('coreutils-9.5-uname-i486.patch')
+ sha256sums+=('9c8b9c88a2f737808ef43dca4c7ea03c638930e33f3c01e7c407ec6f9f67f218')
fi
# FS#66506: temporarily ignore test-login failure
diff --git a/core/coreutils/coreutils-8.30-uname-i486.patch b/core/coreutils/coreutils-8.30-uname-i486.patch
deleted file mode 100644
index f7872693..00000000
--- a/core/coreutils/coreutils-8.30-uname-i486.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN coreutils-8.30/src/uname.c coreutils-8.30-uname-patch-i486/src/uname.c
---- coreutils-8.30/src/uname.c 2018-05-14 06:20:24.000000000 +0200
-+++ coreutils-8.30-uname-patch-i486/src/uname.c 2019-01-28 21:12:09.151041534 +0100
-@@ -285,6 +285,8 @@
-
- if (uname (&name) == -1)
- die (EXIT_FAILURE, errno, _("cannot get system name"));
-+
-+ strcpy(name.machine, "i486");
-
- if (toprint & PRINT_KERNEL_NAME)
- print_element (name.sysname);
diff --git a/core/coreutils/coreutils-9.5-uname-i486.patch b/core/coreutils/coreutils-9.5-uname-i486.patch
new file mode 100644
index 00000000..7250be30
--- /dev/null
+++ b/core/coreutils/coreutils-9.5-uname-i486.patch
@@ -0,0 +1,12 @@
+diff -rauN coreutils-9.5/src/uname.c coreutils-9.5-uname-i486-patch/src/uname.c
+--- coreutils-9.5/src/uname.c 2024-01-01 14:27:23.000000000 +0100
++++ coreutils-9.5-uname-i486-patch/src/uname.c 2024-04-26 08:25:24.914671684 +0200
+@@ -298,6 +298,8 @@
+
+ if (uname (&name) == -1)
+ error (EXIT_FAILURE, errno, _("cannot get system name"));
++
++ strcpy(name.machine, "i486");
+
+ if (toprint & PRINT_KERNEL_NAME)
+ print_element_env (name.sysname, "UNAME_SYSNAME");