Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2024-03-09 16:48:08 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2024-03-09 16:48:08 +0100
commit4c2f2615f13fda56ef3e545539379762f740666b (patch)
tree43a099317860d7de81c3d05216f28346642b1d22 /core
parent6bcdb9078a7b1d3d72343c64c4952f865c36c325 (diff)
core/libfido2: we should really check in only the diff
Diffstat (limited to 'core')
-rw-r--r--core/libfido2/PKGBUILD49
1 files changed, 0 insertions, 49 deletions
diff --git a/core/libfido2/PKGBUILD b/core/libfido2/PKGBUILD
index ee4d26f4..3e4475a6 100644
--- a/core/libfido2/PKGBUILD
+++ b/core/libfido2/PKGBUILD
@@ -1,52 +1,3 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Contributor: Karol Babioch <karol@babioch.de>
-
-pkgname=libfido2
-pkgver=1.14.0
-pkgrel=2
-pkgdesc='Library functionality for FIDO 2.0, including communication with a device over USB'
-url='https://developers.yubico.com/libfido2/'
-arch=(i486 i686 pentium4 'x86_64')
-license=('BSD')
-depends=('glibc' 'openssl' 'libcbor' 'libcbor.so' 'hidapi' 'systemd-libs' 'libudev.so' 'zlib')
-makedepends=('cmake' 'systemd')
-provides=('libfido2.so')
-source=("https://developers.yubico.com/libfido2/Releases/libfido2-${pkgver}.tar.gz"{,.sig})
-sha512sums=('83454b0db0cc8546f377d0dd59f95785fe6b73cf28e499a6182a6ece4b7bce17c3e750155262adf71f339ec0b3b6c3d3d64a07b01c8428b4b91de97ae768f0e6'
- 'SKIP')
-b2sums=('244ad33f73e7aeb3e4523eeda8402c0fcb9de08d28d15d5881651ca5e05b78b4bec10fe58c33dda08e8b5f7be231bf36a85463ded2733d762e929414e4749765'
- 'SKIP')
-validpgpkeys=(
- 'EE90AE0D19774C8386628FAAB428949EF7914718' # pedro martelletto <pedro@yubico.com>
- '1D7308B0055F5AEF36944A8F27A9C24D9588EA0F' # Aveen Ismail <aveen.ismail@yubico.com>
- '7FBB6186957496D58C751AC20E777DD85755AA4A' # Konstantinos Georgantas <kostas@yubico.com>
- '78D997D53E9C0A2A205392ED14A19784723C9988' # Ludvig Michaelsson <ludvig.michaelsson@yubico.com>
-)
-
-build() {
- cd ${pkgname}-${pkgver}
- # do not use bundled udev rules superseded by systemd
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_C_FLAGS="${CFLAGS} ${CPPFLAGS}" \
- -Wno-dev \
- -S .
- make -C build VERBOSE=1
-}
-
-package() {
- cd ${pkgname}-${pkgver}
- make -C build DESTDIR="${pkgdir}" install
- install -Dm 644 NEWS README.adoc -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
-}
-
-# vim: ts=2 sw=2 et:
-
-# Arch32
-
# break cycles with systemd
depends=(${depends[@]//systemd-libs/})
makedepends=(${makedepends[@]//systemd/})