Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/systemd
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-07-24 08:17:57 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-07-24 08:17:57 +0200
commitcef29f852c4ff913b9cf764408403bce635bdb5e (patch)
treec6e772d6c8ff0be9bc06cef0096ed81f69587076 /core/systemd
parent78fe26e18eafd52e5ef911958e82599466334c48 (diff)
core/systemd: removed efi patch (fixed upstream)
Diffstat (limited to 'core/systemd')
-rw-r--r--core/systemd/PKGBUILD11
-rw-r--r--core/systemd/fix-23609-efi-ia32.patch12
2 files changed, 0 insertions, 23 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index ccec11a5..dc8fe0c5 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -28,14 +28,3 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
fi
-
-# see upstream https://github.com/systemd/systemd/pull/23609 and
-# https://github.com/systemd/systemd/commit/38c87ca2ab96d085158485ecfc46c7cb6af0f166
-source+=('fix-23609-efi-ia32.patch')
-sha512sums+=('1ebcfd699894d62520f9a02a05e966b24e8152b9ab72646e8d0a47212244bd83202bffb4a019f610ace64deaffee24c359d991d08c2e45eae413a55b576b940f')
-eval "$(
- declare -f prepare | \
- sed '
- $ i patch -Np1 < ../fix-23609-efi-ia32.patch
- '
-)"
diff --git a/core/systemd/fix-23609-efi-ia32.patch b/core/systemd/fix-23609-efi-ia32.patch
deleted file mode 100644
index 7bfd421a..00000000
--- a/core/systemd/fix-23609-efi-ia32.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN a/src/fundamental/sha256.c b/src/fundamental/sha256.c
---- a/src/fundamental/sha256.c 2022-06-03 18:23:03.582446505 +0200
-+++ b/src/fundamental/sha256.c 2022-06-03 18:23:13.382479050 +0200
-@@ -58,7 +58,7 @@
- # define UNALIGNED_P(p) (((size_t) p) % sizeof(uint32_t) != 0)
- # endif
- #else
--# define UNALIGNED_P(p) false
-+# define UNALIGNED_P(p) sd_false
- #endif
-
- /* This array contains the bytes used to pad the buffer to the next