Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/systemd
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-11-07 07:22:49 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2018-11-07 07:22:49 +0100
commit54f622c30c17779f0baf224dd61b765f84213c04 (patch)
tree12594a95de52f85e9a2d0fb6518584ba8d794d1a /core/systemd
parent4da8f8f7633978813e090c0484d3b29179cc164a (diff)
core/systemd: removed temporary patch for debug in meson
Diffstat (limited to 'core/systemd')
-rw-r--r--core/systemd/PKGBUILD23
-rw-r--r--core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch26
2 files changed, 0 insertions, 49 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
deleted file mode 100644
index baf567fc..00000000
--- a/core/systemd/PKGBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-source+=('meson-rename-Ddebug-to-Ddebug-extra.patch')
-sha512sums+=('d310e7ea099bd371eb12fb4f474f1518ddc1013612d6a53c3f5777e6a3509eb58c4b5989d31bb04784be70db5d8ca39bff47414456c3fe322194cd7b341ae70c')
-
-eval "$(
- declare -f prepare | \
- sed '
- /patch.*0001.*/a patch -Np1 -i ../meson-rename-Ddebug-to-Ddebug-extra.patch
- '
-)"
-
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
- # temporary, as there is no systemd-journal user for some reason!?
- eval "$(
- declare -f package_systemd | \
- sed '
- /install.*systemd-journal/d
- '
- )"
-
- # tempoary failure, known upstream, see FS#60239
- unset check
-fi
diff --git a/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch b/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
deleted file mode 100644
index 12607f2a..00000000
--- a/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 88a470a..1d864e3 100644
---- a/meson.build
-+++ b/meson.build
-@@ -765,7 +765,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
-
- enable_debug_hashmap = false
- enable_debug_mmap_cache = false
--foreach name : get_option('debug')
-+foreach name : get_option('debug-extra')
- if name == 'hashmap'
- enable_debug_hashmap = true
- elif name == 'mmap-cache'
-diff --git a/meson_options.txt b/meson_options.txt
-index 16c1f2b..dc7951b 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -46,7 +46,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
- description : 'path to debug shell binary')
- option('debug-tty', type : 'string', value : '/dev/tty9',
- description : 'specify the tty device for debug shell')
--option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
-+option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
- description : 'enable extra debugging')
- option('memory-accounting-default', type : 'boolean',
- description : 'enable MemoryAccounting= by default')