Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/systemd/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-07-22 15:36:55 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-07-22 15:36:55 +0200
commitb07b4b215d47d9d5723bcf2d4a204bf7320bb145 (patch)
treea51a777785f7109464daaaaeb47b677c74b19681 /core/systemd/PKGBUILD
parent9d713ea35d7bfd193fb65c55483e752ad026efed (diff)
core/systemd: patching SBAT data for Archlinux32
Diffstat (limited to 'core/systemd/PKGBUILD')
-rw-r--r--core/systemd/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 6b71579b..ccec11a5 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -1,3 +1,13 @@
+# replace SBAT data
+eval "$(
+ declare -f build | \
+ sed '
+ s/-Dsbat-distro='"'"'arch'"'"'/-Dsbat-distro='"'"'arch32'"'"'/g
+ s/-Dsbat-distro-summary='"'"'Arch Linux'"'"'/-Dsbat-distro-summary='"'"'Arch Linux 32'"'"'/g
+ s|-Dsbat-distro-url="[^"]*"|-Dsbat-distro-url="https://archlinux32.org/packages/core/${CARCH}/${pkgname}"|g
+ '
+)"
+
# some tests run into timeouts
eval "$(
declare -f check | \