Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/pcre2
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-06 19:21:17 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-06 19:21:17 +0000
commite80107601b421d87ce510d6c976a83c59036d578 (patch)
treef4a2e5ce9d5ff37ef8f3155f06b871110573cd2c /core/pcre2
parent5f4e03b5db3ea32f5d6ac10b6bac55970e7dcd7a (diff)
core/pcre2: added i486 specific patches
Diffstat (limited to 'core/pcre2')
-rw-r--r--core/pcre2/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/core/pcre2/PKGBUILD b/core/pcre2/PKGBUILD
new file mode 100644
index 00000000..0cf66cff
--- /dev/null
+++ b/core/pcre2/PKGBUILD
@@ -0,0 +1,15 @@
+# 486-specific: we have no Vala or Java at the moment
+if [ "${CARCH}" = "i486" ]; then
+ # pcre2 configure, overload CFLAGS and CXXFLAGS to avoid optimization
+ # using MMX registers (default in gcc)
+ # disable JIT, contains hard coded XMM registers
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@CFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" CXXFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" ./configure@
+ s/--enable-jit/--disable-jit/
+ '
+ )"
+
+
+fi