Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/pacman
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2024-02-16 09:39:08 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2024-02-16 09:39:08 +0100
commitde174fcd24d098bfbe6da1c61f76b475dd086597 (patch)
tree6c748bb3d9f5861581a625cbd8534780b0b5ab2b /core/pacman
parent23b1aed61f77a791b4e6adc9a7918d6da8535379 (diff)
core/pacman: synched pacman.conf/makepkg.conf with changes from upstream
Diffstat (limited to 'core/pacman')
-rw-r--r--core/pacman/PKGBUILD4
-rw-r--r--core/pacman/makepkg.conf9
-rw-r--r--core/pacman/pacman.conf5
3 files changed, 12 insertions, 6 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index f38a577b..2126491b 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -5,10 +5,10 @@ depends+=(archlinux32-keyring)
# fail if upstream changes makepkg.conf or pacman.conf
for ((i=0; i<${#sha256sums[@]}; i++)); do
if [ "${sha256sums[${i}]}" = 'f2791b51588104ec6dbaafa389451056f3c61fa6c19510dcce3a9a6cc19cba29' ]; then
- sha256sums[${i}]='2ad58ba534fed9d728d273c7b5920a495c15cfb58b5c3864bfa023a939abc5d0'
+ sha256sums[${i}]='d7e2516889c62cd3d0c1f2af5199fe0564c5ef35900d6b6551a8c9ce1c80f95a'
fi
if [ "${sha256sums[${i}]}" = '656c4d4cb8cb12adbf178fc8cb2fd25f8c285d6572bbdbb24d865d00e0d5a85a' ]; then
- sha256sums[${i}]='fa05e6f8a83f09fc347988a8ad9dce6fad50d542b2d77fc07fd1b604309990be'
+ sha256sums[${i}]='663cbfe0643ff78c1eeb38d59046707da49bde6ab8226fbc5844457a985cb5bc'
fi
done
diff --git a/core/pacman/makepkg.conf b/core/pacman/makepkg.conf
index 12bd0a97..d333a442 100644
--- a/core/pacman/makepkg.conf
+++ b/core/pacman/makepkg.conf
@@ -1,4 +1,6 @@
#!/hint/bash
+# shellcheck disable=2034
+
#
# /etc/makepkg.conf
#
@@ -23,7 +25,7 @@ DLAGENTS=('file::/usr/bin/curl -qgC - -o %o %u'
#-- The package required by makepkg to download VCS sources
# Format: 'protocol::package'
-VCSCLIENTS=('bzr::bzr'
+VCSCLIENTS=('bzr::breezy'
'fossil::fossil'
'git::git'
'hg::mercurial'
@@ -44,13 +46,13 @@ CFLAGS="-march=i686 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
LTOFLAGS="-flto=auto"
-#RUSTFLAGS="-C opt-level=2"
+RUSTFLAGS=""
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
#-- Debugging flags
DEBUG_CFLAGS="-g"
DEBUG_CXXFLAGS="$DEBUG_CFLAGS"
-#DEBUG_RUSTFLAGS="-C debuginfo=2"
+DEBUG_RUSTFLAGS="-C debuginfo=2"
#########################################################################
# BUILD ENVIRONMENT
@@ -157,3 +159,4 @@ SRCEXT='.src.tar.gz'
#
#-- Command used to run pacman as root, instead of trying sudo and su
#PACMAN_AUTH=()
+# vim: set ft=sh ts=2 sw=2 et:
diff --git a/core/pacman/pacman.conf b/core/pacman/pacman.conf
index ef347ade..75ba5b82 100644
--- a/core/pacman/pacman.conf
+++ b/core/pacman/pacman.conf
@@ -70,12 +70,15 @@ LocalFileSigLevel = Optional
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.
-#[testing]
+#[core-testing]
#Include = /etc/pacman.d/mirrorlist
[core]
Include = /etc/pacman.d/mirrorlist
+#[extra-testing]
+#Include = /etc/pacman.d/mirrorlist
+
[extra]
Include = /etc/pacman.d/mirrorlist