Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/m4
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-02-13 23:24:41 +0100
committerErich Eckner <git@eckner.net>2023-02-13 23:24:41 +0100
commite8aa8914b276efd49eba297669afe04d3ccf311e (patch)
tree60520536c18dbb3d9d88bc285621474fd876cf9f /core/m4
parent56232876ea631554ae0b83616442de7933218825 (diff)
core/m4: remove residual stuff
Diffstat (limited to 'core/m4')
-rw-r--r--core/m4/PKGBUILD10
-rw-r--r--core/m4/m4-1.4.18-glibc-change-work-around.patch115
2 files changed, 0 insertions, 125 deletions
diff --git a/core/m4/PKGBUILD b/core/m4/PKGBUILD
deleted file mode 100644
index 594f9db2..00000000
--- a/core/m4/PKGBUILD
+++ /dev/null
@@ -1,10 +0,0 @@
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/$pkgname-$pkgver" \
- echo "#define _IO_IN_BACKUP 0x100" >> lib/stdio-impl.h
- '
-)"
diff --git a/core/m4/m4-1.4.18-glibc-change-work-around.patch b/core/m4/m4-1.4.18-glibc-change-work-around.patch
deleted file mode 100644
index 582ae9b5..00000000
--- a/core/m4/m4-1.4.18-glibc-change-work-around.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-diff -up m4-1.4.18/lib/fflush.c.orig m4-1.4.18/lib/fflush.c
---- m4-1.4.18/lib/fflush.c.orig 2018-05-02 12:35:59.536851666 +0200
-+++ m4-1.4.18/lib/fflush.c 2018-05-02 12:37:02.768958606 +0200
-@@ -33,7 +33,7 @@
- #undef fflush
-
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-
- /* Clear the stream's ungetc buffer, preserving the value of ftello (fp). */
- static void
-@@ -72,7 +72,7 @@ clear_ungetc_buffer (FILE *fp)
-
- #endif
-
--#if ! (defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
-+#if ! (defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
-
- # if (defined __sferror || defined __DragonFly__ || defined __ANDROID__) && defined __SNPT
- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
-@@ -148,7 +148,7 @@ rpl_fflush (FILE *stream)
- if (stream == NULL || ! freading (stream))
- return fflush (stream);
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-
- clear_ungetc_buffer_preserving_position (stream);
-
-diff -up m4-1.4.18/lib/fpending.c.orig m4-1.4.18/lib/fpending.c
---- m4-1.4.18/lib/fpending.c.orig 2018-05-02 12:35:32.305806774 +0200
-+++ m4-1.4.18/lib/fpending.c 2018-05-02 12:35:44.944827347 +0200
-@@ -32,7 +32,7 @@ __fpending (FILE *fp)
- /* Most systems provide FILE as a struct and the necessary bitmask in
- <stdio.h>, because they need it for implementing getc() and putc() as
- fast macros. */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- return fp->_IO_write_ptr - fp->_IO_write_base;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
-diff -up m4-1.4.18/lib/fpurge.c.orig m4-1.4.18/lib/fpurge.c
---- m4-1.4.18/lib/fpurge.c.orig 2018-05-02 12:38:13.586078669 +0200
-+++ m4-1.4.18/lib/fpurge.c 2018-05-02 12:38:38.785121867 +0200
-@@ -62,7 +62,7 @@ fpurge (FILE *fp)
- /* Most systems provide FILE as a struct and the necessary bitmask in
- <stdio.h>, because they need it for implementing getc() and putc() as
- fast macros. */
--# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_IO_read_end = fp->_IO_read_ptr;
- fp->_IO_write_ptr = fp->_IO_write_base;
- /* Avoid memory leak when there is an active ungetc buffer. */
-diff -up m4-1.4.18/lib/freadahead.c.orig m4-1.4.18/lib/freadahead.c
---- m4-1.4.18/lib/freadahead.c.orig 2016-12-31 14:54:41.000000000 +0100
-+++ m4-1.4.18/lib/freadahead.c 2018-05-02 11:43:19.570336724 +0200
-@@ -25,7 +25,7 @@
- size_t
- freadahead (FILE *fp)
- {
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- if (fp->_IO_write_ptr > fp->_IO_write_base)
- return 0;
- return (fp->_IO_read_end - fp->_IO_read_ptr)
-diff -up m4-1.4.18/lib/freading.c.orig m4-1.4.18/lib/freading.c
---- m4-1.4.18/lib/freading.c.orig 2018-05-02 12:37:33.970011368 +0200
-+++ m4-1.4.18/lib/freading.c 2018-05-02 12:37:59.393054359 +0200
-@@ -31,7 +31,7 @@ freading (FILE *fp)
- /* Most systems provide FILE as a struct and the necessary bitmask in
- <stdio.h>, because they need it for implementing getc() and putc() as
- fast macros. */
--# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- return ((fp->_flags & _IO_NO_WRITES) != 0
- || ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
- && fp->_IO_read_base != NULL));
-diff -up m4-1.4.18/lib/fseeko.c.orig m4-1.4.18/lib/fseeko.c
---- m4-1.4.18/lib/fseeko.c.orig 2018-05-02 11:44:17.947460233 +0200
-+++ m4-1.4.18/lib/fseeko.c 2018-05-02 12:39:49.537216897 +0200
-@@ -47,7 +47,7 @@ fseeko (FILE *fp, off_t offset, int when
- #endif
-
- /* These tests are based on fpurge.c. */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- if (fp->_IO_read_end == fp->_IO_read_ptr
- && fp->_IO_write_ptr == fp->_IO_write_base
- && fp->_IO_save_base == NULL)
-@@ -123,7 +123,7 @@ fseeko (FILE *fp, off_t offset, int when
- return -1;
- }
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_flags &= ~_IO_EOF_SEEN;
- fp->_offset = pos;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
-diff -up m4-1.4.18/lib/stdio-impl.h.orig m4-1.4.18/lib/stdio-impl.h
---- m4-1.4.18/lib/stdio-impl.h.orig 2016-12-31 14:54:42.000000000 +0100
-+++ m4-1.4.18/lib/stdio-impl.h 2018-05-02 11:43:19.570336724 +0200
-@@ -18,6 +18,12 @@
- the same implementation of stdio extension API, except that some fields
- have different naming conventions, or their access requires some casts. */
-
-+/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
-+ problem by defining it ourselves. FIXME: Do not rely on glibc
-+ internals. */
-+#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
-+# define _IO_IN_BACKUP 0x100
-+#endif
-
- /* BSD stdio derived implementations. */
-