Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-12-02 11:49:53 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-12-02 11:49:53 +0100
commit73b4e4d28d8b905d600ad7c82dcaedbb32688cf9 (patch)
treebe170f60bb0a11c9badf02815377f876707ce14d /core/linux
parent838653459a9ae0ab064da00dafab5f868465daf3 (diff)
core/linux: updated to 6.0.10
Diffstat (limited to 'core/linux')
-rw-r--r--core/linux/PKGBUILD10
-rw-r--r--core/linux/config.i4863
-rw-r--r--core/linux/config.i6863
-rw-r--r--core/linux/config.pentium43
4 files changed, 11 insertions, 8 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index e9293bb2..03b54081 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,14 +1,14 @@
-# upstream git revision: 78c5e640bc52305e08f76c2c30cb2a1e415fba14
+# upstream git revision: 838653459a9ae0ab064da00dafab5f868465daf3
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '05168cbbeb6378eec6c84fe3300cede4fa5cf6130c39fb8af95040529bd390a6' ]; then
- sha256sums_pentium4=('c08801bb4242d76d8f61e551d515dac57691ff2b970e3af10dcb7b648ac98c2e')
- sha256sums_i686=('c864d0bea33ed5056336d5db62470cb4bd24cdbb84cb6b7aa01dcbb26a3c7008')
- sha256sums_i486=('3884927e5fe250646bd2e4d6cb32659773c8528493d20bc2e7ba98e8a17e8690')
+ if [ "${sha256sums[${i}]}" = '848ccd048f91b17f0e0192d2900c462986eeacf78bb578b2de9498c4a0526983' ]; then
+ sha256sums_pentium4=('6bfd2a749b24f652a85cf4c0e0f17ce5d0253d22fda8bb80a0801ba6d7265a82')
+ sha256sums_i686=('04595232e215dcccc674451bac926b5ce02727c1cd7f352e3847df1157d9287c')
+ sha256sums_i486=('6b50d2114412b9c9c10278aa2e168064bc9dfdf2066999347097186d026a3ac7')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index 95b4f519..9492ee26 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.0.8-arch1 Kernel Configuration
+# Linux/x86 6.0.10-arch2 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
CONFIG_CC_IS_GCC=y
@@ -11,6 +11,7 @@ CONFIG_AS_VERSION=23900
CONFIG_LD_IS_BFD=y
CONFIG_LD_VERSION=23900
CONFIG_LLD_VERSION=0
+CONFIG_CC_CAN_LINK_STATIC=y
CONFIG_CC_HAS_ASM_GOTO_OUTPUT=y
CONFIG_CC_HAS_ASM_GOTO_TIED_OUTPUT=y
CONFIG_CC_HAS_ASM_INLINE=y
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index 643afbbb..53d976c5 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.0.8-arch1 Kernel Configuration
+# Linux/x86 6.0.10-arch2 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
CONFIG_CC_IS_GCC=y
@@ -11,6 +11,7 @@ CONFIG_AS_VERSION=23900
CONFIG_LD_IS_BFD=y
CONFIG_LD_VERSION=23900
CONFIG_LLD_VERSION=0
+CONFIG_CC_CAN_LINK_STATIC=y
CONFIG_CC_HAS_ASM_GOTO_OUTPUT=y
CONFIG_CC_HAS_ASM_GOTO_TIED_OUTPUT=y
CONFIG_CC_HAS_ASM_INLINE=y
diff --git a/core/linux/config.pentium4 b/core/linux/config.pentium4
index 2486d59c..e26f20d3 100644
--- a/core/linux/config.pentium4
+++ b/core/linux/config.pentium4
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.0.8-arch1 Kernel Configuration
+# Linux/x86 6.0.10-arch2 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
CONFIG_CC_IS_GCC=y
@@ -11,6 +11,7 @@ CONFIG_AS_VERSION=23900
CONFIG_LD_IS_BFD=y
CONFIG_LD_VERSION=23900
CONFIG_LLD_VERSION=0
+CONFIG_CC_CAN_LINK_STATIC=y
CONFIG_CC_HAS_ASM_GOTO_OUTPUT=y
CONFIG_CC_HAS_ASM_GOTO_TIED_OUTPUT=y
CONFIG_CC_HAS_ASM_INLINE=y