Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-14 02:26:06 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-14 02:26:06 +0200
commita226c63bc3923273be2d3ebd9c860de5cdc8ea4a (patch)
tree7051d6f5f95de1ea3b2dc308f3df8df9bed0d161 /core/linux/PKGBUILD
parent16fc46cb294640453c4db9f62f45639b0ac3f129 (diff)
core/linux: Don't run bpftool
Diffstat (limited to 'core/linux/PKGBUILD')
-rw-r--r--core/linux/PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index b95e4c39..7ee56472 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -120,7 +120,8 @@ b2sums+=('165ab9dd8cedeaae5327accc1581c19cf0be55f923b03feb889cad3351b74c7c4cd3d3
eval "$(
declare -f package_${pkgbase}-headers | \
sed '/objtool/d' | \
- sed '/resolve_btfids/d'
+ sed '/resolve_btfids/d' | \
+ sed 's@tools/bpf/bpftool/vmlinux.h@@'
)"
# temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
@@ -130,11 +131,12 @@ pkgname=(
grep -v '^\$pkgbase-docs'
)
)
+
+# Also avoid building/running bpftool
eval "$(
declare -f build | \
- sed '
- s/\bhtmldocs\b//
- '
+ sed '/htmldocs/d' | \
+ sed '/bpftool/d'
)"
makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
makedepends=(${makedepends[@]//python-sphinx<6.0.0/})