Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-13 22:19:18 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-13 22:19:18 +0200
commit50a97ef6bbe3ffaeb1835594bcd4e260fb6ab0a3 (patch)
tree0455fa23b31febbe4220999896529dc42e3482da /core/linux/PKGBUILD
parent251e4b012775cea61083516547e705cdb664819f (diff)
core/linux: Sync patching with lts
Diffstat (limited to 'core/linux/PKGBUILD')
-rw-r--r--core/linux/PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 55399ae0..0526cdfa 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,20 +1,13 @@
-# upstream git revision: 3ee8900562726ca75feddde13bef02b5d046938d
+# Don't bother with sha256sums, use blake2 only
+unset sha256sums
-
-source+=('config.x86_64')
-sha256sums+=('04143712e593d45a597661fe00f89cf92d52c62df3468c68a46c952c2ef4db64')
-b2sums+=('21083151bdcd0fc2bcc0475b9cd73bab5666a71f043eedd67b19a3a4c09c8253a5a06794ce9270215782f5885e05e70b5e424123f1bded7aa7a6d3f30d02a4b3')
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
-# fail if upstream's .config changes
-for ((i=0; i<${#b2sums[@]}; i++)); do
- if [ "${b2sums[${i}]}" = '21083151bdcd0fc2bcc0475b9cd73bab5666a71f043eedd67b19a3a4c09c8253a5a06794ce9270215782f5885e05e70b5e424123f1bded7aa7a6d3f30d02a4b3' ]; then
- b2sums_pentium4=('be2d28230e649b7667936de205a9a89a88d3805bb18a29e24f565f53fefd1b2583cb1e26b339dbbb0314476186cb0f9530c5acdc61624e8b65f8859093ae9f72')
- b2sums_i686=('d7c72c803747aa665fe94242b2ba8afda78ce47356221d30a0bd41eb9f29dc95896c733b032739717421d1b7b87906d3ca87fb9e6a2286450302794cbf50b5c8')
- b2sums_i486=('84f06145ddf54f9c4503f07dc6c313d99878141c6e5559224dc9ac4c6c1d462d845d6a9cb10bd7df22f24ccd06f44d94fde47df2374df8c50a7edf7840083ea5')
- fi
-done
+b2sums_pentium4=('be2d28230e649b7667936de205a9a89a88d3805bb18a29e24f565f53fefd1b2583cb1e26b339dbbb0314476186cb0f9530c5acdc61624e8b65f8859093ae9f72')
+b2sums_i686=('d7c72c803747aa665fe94242b2ba8afda78ce47356221d30a0bd41eb9f29dc95896c733b032739717421d1b7b87906d3ca87fb9e6a2286450302794cbf50b5c8')
+b2sums_i486=('84f06145ddf54f9c4503f07dc6c313d99878141c6e5559224dc9ac4c6c1d462d845d6a9cb10bd7df22f24ccd06f44d94fde47df2374df8c50a7edf7840083ea5')
+
# copy architecture specific config file, not default 'config'
eval "$(
@@ -26,9 +19,8 @@ eval "$(
# patch architecture when copying the kernel Makefile
eval "$(
- declare -f package_linux-headers | \
+ declare -f package_${pkgbase}-headers | \
sed '
- \,/tools/objtool" ,d
\,arch/x86/Makefile, {
a \
install -t "${builddir}/arch/x86" -m644 arch/x86/Makefile_32.cpu
@@ -121,9 +113,16 @@ done
# avoid using zstd compression in ultra mode (exhausts virtual memory)
source+=('no-ultra-zstd.patch')
-sha256sums+=('d32270be5fd9c3e3ba50f3aef33f6cfcb85be0c8216f03b777287cc621fdff28')
b2sums+=('165ab9dd8cedeaae5327accc1581c19cf0be55f923b03feb889cad3351b74c7c4cd3d3c206938e5152bfe1d947513dea8f630f8f5544099ec13d16d254725c40')
+# objtool doesn't exist because we don't have STACK_VALIDATION
+# and resolve_btfids doesn't exist because we disable BTF due to pahole running out of memory
+eval "$(
+ declare -f package_${pkgbase}-headers | \
+ sed '/objtool/d' | \
+ sed '/resolve_btfids/d'
+)"
+
# temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
pkgname=(
$(