Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux-lts/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-14 04:34:17 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-14 04:34:17 +0200
commitc371904d4f791837aadea341c52323a250a71592 (patch)
tree017001b92a7759f697e1d3c1d20dd4caaf088614 /core/linux-lts/PKGBUILD
parent9511501b5c68055a1221d93ac83165eba6fe1db5 (diff)
extra/linux-pae: Set pkgbase to linux-pae
Diffstat (limited to 'core/linux-lts/PKGBUILD')
-rw-r--r--core/linux-lts/PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/core/linux-lts/PKGBUILD b/core/linux-lts/PKGBUILD
index 6e86230d..9b40a960 100644
--- a/core/linux-lts/PKGBUILD
+++ b/core/linux-lts/PKGBUILD
@@ -8,6 +8,7 @@ b2sums_pentium4=('c2fa0bef869355e68553944d0a33e6089d752fef862262633e24c934914749
b2sums_i686=('c2fa0bef869355e68553944d0a33e6089d752fef862262633e24c9349147496c9c1a20e0d1790341e716ab86ae6e9f6863841baf773e8511c0d7351c73897642')
b2sums_i486=('c2fa0bef869355e68553944d0a33e6089d752fef862262633e24c9349147496c9c1a20e0d1790341e716ab86ae6e9f6863841baf773e8511c0d7351c73897642')
+
# copy architecture specific config file, not default 'config'
eval "$(
declare -f prepare | \
@@ -119,7 +120,8 @@ b2sums+=('e7915714b504b92155c983a30df6d97966c14520dc9eb004671003dbdecf454b061138
eval "$(
declare -f package_${pkgbase}-headers | \
sed '/objtool/d' | \
- sed '/resolve_btfids/d'
+ sed '/resolve_btfids/d' | \
+ sed 's@tools/bpf/bpftool/vmlinux.h@@'
)"
# temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
@@ -129,11 +131,12 @@ pkgname=(
grep -v '^\$pkgbase-docs'
)
)
+
+# Also avoid building/running bpftool
eval "$(
declare -f build | \
- sed '
- s/\bhtmldocs\b//
- '
+ sed '/htmldocs/d' | \
+ sed '/bpftool/d'
)"
makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
makedepends=(${makedepends[@]//python-sphinx<6.0.0/})