Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux-lts/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-13 20:25:31 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-13 20:25:31 +0200
commit251e4b012775cea61083516547e705cdb664819f (patch)
tree684a8bc16eb9296c80431d12db81eba245ad120f /core/linux-lts/PKGBUILD
parent155a4c030d66981320b5d18509cc6055eebd4311 (diff)
core/linux-lts: Fix patching
Diffstat (limited to 'core/linux-lts/PKGBUILD')
-rw-r--r--core/linux-lts/PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/core/linux-lts/PKGBUILD b/core/linux-lts/PKGBUILD
index 40554ed8..6e86230d 100644
--- a/core/linux-lts/PKGBUILD
+++ b/core/linux-lts/PKGBUILD
@@ -1,5 +1,3 @@
-# upstream git revision: d70c1e882bf3a02e734ec7f29f911ebb42912b8a
-
# Don't bother with sha256sums, use blake2 only
unset sha256sums
@@ -20,9 +18,8 @@ eval "$(
# patch architecture when copying the kernel Makefile
eval "$(
- declare -f package_linux-headers | \
+ declare -f package_${pkgbase}-headers | \
sed '
- \,/tools/objtool" ,d
\,arch/x86/Makefile, {
a \
install -t "${builddir}/arch/x86" -m644 arch/x86/Makefile_32.cpu
@@ -117,6 +114,14 @@ done
source+=('no-ultra-zstd.patch')
b2sums+=('e7915714b504b92155c983a30df6d97966c14520dc9eb004671003dbdecf454b061138a6d237cabe86be32ae2ea4c598cdb821cb1dd52f6a9bfe5e280bffa321')
+# objtool doesn't exist because we don't have STACK_VALIDATION
+# and resolve_btfids doesn't exist because we disable BTF due to pahole running out of memory
+eval "$(
+ declare -f package_${pkgbase}-headers | \
+ sed '/objtool/d' | \
+ sed '/resolve_btfids/d'
+)"
+
# temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
pkgname=(
$(