Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/glibc
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-02-06 00:37:31 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-02-06 00:37:31 +0200
commit12f331bd91b0f02d0109b5457ddc0ae229a1bc4c (patch)
treedda45051f267e58595460c64b732ee0b8a6aedcf /core/glibc
parentef8a69d4a35091dec380dc0577e4a97896376168 (diff)
core/glibc: Disable CET for all architectures
Resolves configure: error: "CET is only supported on x86_64 or x32"
Diffstat (limited to 'core/glibc')
-rw-r--r--core/glibc/PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index 63391bbd..eb3971c3 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -39,15 +39,6 @@ if [ "${CARCH}" = "i486" ]; then
/make -O check/d
'
)"
-
- # disable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet/--disable-cet/
- '
- )"
-
fi
# pentium4 specific
@@ -132,3 +123,11 @@ eval "$(
# ignoring tests for now (they hang, checked manually, see skip_tests above)
unset check
+
+# disable CET (Control Flow instructions endbr32/enbr64)
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-cet/--disable-cet/
+ '
+)"