Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/gcc
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-07-29 12:06:00 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-07-29 12:06:00 +0200
commit299b582c243eba2ec350eefc704f7fc73095086a (patch)
tree59da534bc89e42f3375647d52eb15c9bbe21a627 /core/gcc
parent23e87ad773153a14c2d644dd3af0e22c1b72eb12 (diff)
core/gcc: temporary workarounds to rebuild gdc
Diffstat (limited to 'core/gcc')
-rw-r--r--core/gcc/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/core/gcc/PKGBUILD b/core/gcc/PKGBUILD
index 610273fa..f344cebe 100644
--- a/core/gcc/PKGBUILD
+++ b/core/gcc/PKGBUILD
@@ -128,3 +128,15 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
fi
+
+# solve temporary build problems around the D compiler (requires gcc=11 which no longer
+# exists in the repos, installing it manually in the build section before configure)
+makedepends=(${makedepends[@]//gcc-d/})
+
+eval "$(
+ declare -f build | \
+ sed '
+ /cd gcc-build/ a \
+ sudo pacman -d --noconfirm -S gcc-d
+ '
+)"