Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-03-31 14:57:29 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-03-31 14:57:29 +0200
commitf7f3df0ec531498d4efc969d865901e4071adacd (patch)
tree7709ac92b85af220560173e8c5cf56d99236a601 /community
parent25a265aa7ac11662ba824662fa2f3fa8cf2cd505 (diff)
community/crypto++: patched for non-SSE2 version on i686/i486
Diffstat (limited to 'community')
-rw-r--r--community/crypto++/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/community/crypto++/PKGBUILD b/community/crypto++/PKGBUILD
new file mode 100644
index 00000000..23130381
--- /dev/null
+++ b/community/crypto++/PKGBUILD
@@ -0,0 +1,9 @@
+# disable SSE2 on i686 and i486
+if [ "$CARCH" == 'i686' ] || [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/export CXXFLAGS="\([^"]\+\)"/export CXXFLAGS="\1 -DCRYPTOPP_DISABLE_ASM=1"/g
+ '
+ )"
+fi