Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 09:10:35 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 09:10:35 +0200
commitf1b42b3d18eab8ade8c02ac3dce75af3df742091 (patch)
treea89cbda4009a472f5fed47306fb20209be716afa /community
parentfc9b8c115f0b7b3e8227fcea2a1d8246bc1dd0c7 (diff)
community/ruby-*: rebuilding against ruby with patching for finding shared libraries
Diffstat (limited to 'community')
-rw-r--r--community/ruby-benchmark/PKGBUILD16
-rw-r--r--community/ruby-bigdecimal/PKGBUILD16
-rw-r--r--community/ruby-bundler/PKGBUILD16
-rw-r--r--community/ruby-cgi/PKGBUILD16
-rw-r--r--community/ruby-csv/PKGBUILD16
-rw-r--r--community/ruby-date/PKGBUILD16
-rw-r--r--community/ruby-delegate/PKGBUILD16
-rw-r--r--community/ruby-did_you_mean/PKGBUILD16
-rw-r--r--community/ruby-drb/PKGBUILD16
-rw-r--r--community/ruby-english/PKGBUILD16
-rw-r--r--community/ruby-erb/PKGBUILD16
-rw-r--r--community/ruby-etc/PKGBUILD16
-rw-r--r--community/ruby-fcntl/PKGBUILD16
-rw-r--r--community/ruby-fiddle/PKGBUILD16
-rw-r--r--community/ruby-fileutils/PKGBUILD16
-rw-r--r--community/ruby-find/PKGBUILD16
-rw-r--r--community/ruby-forwardable/PKGBUILD16
-rw-r--r--community/ruby-getoptlong/PKGBUILD16
-rw-r--r--community/ruby-io-console/PKGBUILD16
-rw-r--r--community/ruby-io-nonblock/PKGBUILD16
-rw-r--r--community/ruby-io-wait/PKGBUILD16
-rw-r--r--community/ruby-ipaddr/PKGBUILD16
-rw-r--r--community/ruby-irb/PKGBUILD16
-rw-r--r--community/ruby-json/PKGBUILD16
-rw-r--r--community/ruby-logger/PKGBUILD16
-rw-r--r--community/ruby-minitest/PKGBUILD16
-rw-r--r--community/ruby-mutex_m/PKGBUILD16
-rw-r--r--community/ruby-net-http/PKGBUILD16
-rw-r--r--community/ruby-open-uri/PKGBUILD16
-rw-r--r--community/ruby-racc/PKGBUILD16
-rw-r--r--community/ruby-rdoc/PKGBUILD16
-rw-r--r--community/ruby-reline/PKGBUILD16
-rw-r--r--community/ruby-stringio/PKGBUILD16
-rw-r--r--community/ruby-time/PKGBUILD16
-rw-r--r--community/ruby-tmpdir/PKGBUILD16
-rw-r--r--community/ruby-uri/PKGBUILD16
36 files changed, 360 insertions, 216 deletions
diff --git a/community/ruby-benchmark/PKGBUILD b/community/ruby-benchmark/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-benchmark/PKGBUILD
+++ b/community/ruby-benchmark/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-bigdecimal/PKGBUILD b/community/ruby-bigdecimal/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-bigdecimal/PKGBUILD
+++ b/community/ruby-bigdecimal/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-bundler/PKGBUILD b/community/ruby-bundler/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-bundler/PKGBUILD
+++ b/community/ruby-bundler/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-cgi/PKGBUILD b/community/ruby-cgi/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-cgi/PKGBUILD
+++ b/community/ruby-cgi/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-csv/PKGBUILD b/community/ruby-csv/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-csv/PKGBUILD
+++ b/community/ruby-csv/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-date/PKGBUILD b/community/ruby-date/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-date/PKGBUILD
+++ b/community/ruby-date/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-delegate/PKGBUILD b/community/ruby-delegate/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-delegate/PKGBUILD
+++ b/community/ruby-delegate/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-did_you_mean/PKGBUILD b/community/ruby-did_you_mean/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-did_you_mean/PKGBUILD
+++ b/community/ruby-did_you_mean/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-drb/PKGBUILD b/community/ruby-drb/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-drb/PKGBUILD
+++ b/community/ruby-drb/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-english/PKGBUILD b/community/ruby-english/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-english/PKGBUILD
+++ b/community/ruby-english/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-erb/PKGBUILD b/community/ruby-erb/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-erb/PKGBUILD
+++ b/community/ruby-erb/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-etc/PKGBUILD b/community/ruby-etc/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-etc/PKGBUILD
+++ b/community/ruby-etc/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-fcntl/PKGBUILD b/community/ruby-fcntl/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-fcntl/PKGBUILD
+++ b/community/ruby-fcntl/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-fiddle/PKGBUILD b/community/ruby-fiddle/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-fiddle/PKGBUILD
+++ b/community/ruby-fiddle/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-fileutils/PKGBUILD b/community/ruby-fileutils/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-fileutils/PKGBUILD
+++ b/community/ruby-fileutils/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-find/PKGBUILD b/community/ruby-find/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-find/PKGBUILD
+++ b/community/ruby-find/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-forwardable/PKGBUILD b/community/ruby-forwardable/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-forwardable/PKGBUILD
+++ b/community/ruby-forwardable/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-getoptlong/PKGBUILD b/community/ruby-getoptlong/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-getoptlong/PKGBUILD
+++ b/community/ruby-getoptlong/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-io-console/PKGBUILD b/community/ruby-io-console/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-io-console/PKGBUILD
+++ b/community/ruby-io-console/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-io-nonblock/PKGBUILD b/community/ruby-io-nonblock/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-io-nonblock/PKGBUILD
+++ b/community/ruby-io-nonblock/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-io-wait/PKGBUILD b/community/ruby-io-wait/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-io-wait/PKGBUILD
+++ b/community/ruby-io-wait/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-ipaddr/PKGBUILD b/community/ruby-ipaddr/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-ipaddr/PKGBUILD
+++ b/community/ruby-ipaddr/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-irb/PKGBUILD b/community/ruby-irb/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-irb/PKGBUILD
+++ b/community/ruby-irb/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-json/PKGBUILD b/community/ruby-json/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-json/PKGBUILD
+++ b/community/ruby-json/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-logger/PKGBUILD b/community/ruby-logger/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-logger/PKGBUILD
+++ b/community/ruby-logger/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-minitest/PKGBUILD b/community/ruby-minitest/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-minitest/PKGBUILD
+++ b/community/ruby-minitest/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-mutex_m/PKGBUILD b/community/ruby-mutex_m/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-mutex_m/PKGBUILD
+++ b/community/ruby-mutex_m/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-net-http/PKGBUILD b/community/ruby-net-http/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-net-http/PKGBUILD
+++ b/community/ruby-net-http/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-open-uri/PKGBUILD b/community/ruby-open-uri/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-open-uri/PKGBUILD
+++ b/community/ruby-open-uri/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-racc/PKGBUILD b/community/ruby-racc/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-racc/PKGBUILD
+++ b/community/ruby-racc/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-rdoc/PKGBUILD b/community/ruby-rdoc/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-rdoc/PKGBUILD
+++ b/community/ruby-rdoc/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-reline/PKGBUILD b/community/ruby-reline/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-reline/PKGBUILD
+++ b/community/ruby-reline/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-stringio/PKGBUILD b/community/ruby-stringio/PKGBUILD
index 7f8a166a..472071e2 100644
--- a/community/ruby-stringio/PKGBUILD
+++ b/community/ruby-stringio/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends+=(ruby-bootstrap ruby-rake-compiler-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-time/PKGBUILD b/community/ruby-time/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-time/PKGBUILD
+++ b/community/ruby-time/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-tmpdir/PKGBUILD b/community/ruby-tmpdir/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-tmpdir/PKGBUILD
+++ b/community/ruby-tmpdir/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
diff --git a/community/ruby-uri/PKGBUILD b/community/ruby-uri/PKGBUILD
index e4a5d80a..472071e2 100644
--- a/community/ruby-uri/PKGBUILD
+++ b/community/ruby-uri/PKGBUILD
@@ -1,12 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"