Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-03-26 13:37:55 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-03-26 13:37:55 +0200
commiteccf5849f3c6cb85002cd964b2c18fb8eecad079 (patch)
treeffd0e17979cfe8c3ddd0b983906964c6e13b29c6 /community
parent49c3266d5c47bb09b40b2e4f2bd48ec79baad17d (diff)
community/luajit: moved patching from build to prepare (where it belongs)
Diffstat (limited to 'community')
-rw-r--r--community/luajit/PKGBUILD49
1 files changed, 7 insertions, 42 deletions
diff --git a/community/luajit/PKGBUILD b/community/luajit/PKGBUILD
index d11a7be7..b4f8c113 100644
--- a/community/luajit/PKGBUILD
+++ b/community/luajit/PKGBUILD
@@ -1,40 +1,3 @@
-# Maintainer: Daurnimator <daurnimator@archlinux.org>
-# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
-# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
-# Contributor: Chris Brannon <chris@the-brannons.com>
-# Contributor: Paulo Matias <matiasΘarchlinux-br·org>
-# Contributor: Anders Bergh <anders1@gmail.com>
-
-pkgname=luajit
-# LuaJIT has abandoned versioned releases and now advises using git HEAD
-# https://github.com/LuaJIT/LuaJIT/issues/665#issuecomment-784452583
-_commit=505e2c03de35e2718eef0d2d3660712e06dadf1f
-pkgver="2.1.0.beta3.r471.g${_commit::8}"
-pkgrel=1
-pkgdesc='Just-in-time compiler and drop-in replacement for Lua 5.1'
-arch=(i486 i686 pentium4 'x86_64')
-url='https://luajit.org/'
-license=('MIT')
-depends=('gcc-libs')
-source=("LuaJIT-${_commit}.tar.gz::https://repo.or.cz/luajit-2.0.git/snapshot/${_commit}.tar.gz")
-md5sums=('0847dc535736846a9a1436e18d8c509d')
-sha256sums=('b89d081aac4189a06b736c667f47cc60e0cc4591933b7ed50db38cf58496386e')
-b2sums=('89bed923ff34d2de813dee17f130496ffeaa6bc5caf9252be1df7d35e87fa7398930f1fe35f95650694d344bc99d5b2c0c4abc4568f1dac318822a832d44c3a4')
-
-build() {
- cd "luajit-2.0-${_commit::7}"
- # Avoid early stripping
- make amalg PREFIX=/usr BUILDMODE=dynamic TARGET_STRIP=" @:"
-}
-
-package() {
- cd "luajit-2.0-${_commit::7}"
-
- make install DESTDIR="$pkgdir" PREFIX=/usr
- install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
-
- ln -sf luajit-2.1.0-beta3 "$pkgdir/usr/bin/luajit"
-}
# Re-enable x87 support for i686 CPUs (fix from KitsuWhooa)
if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
source+=('c7815e1a1b49871e645252bb12e722fb4879df11.patch')
@@ -42,10 +5,12 @@ if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
sha256sums+=('a711e1d7ad7a16d0e6ba044fedc284cc0c4bee710c2d910fd9f0f0af8765c1a7')
b2sums+=('2d79b2dad25ba3a771348cfd38883334f511de703d2ccfdd00b808867ecf53201d680388c730aaf8941cb5159f6b819020c2da04b75346bc42428973c7f27420')
eval "$(
- declare -f build | \
- sed '
- /make/ i \
- patch -p1 -i "$srcdir/c7815e1a1b49871e645252bb12e722fb4879df11.patch"
- '
+ {
+ declare -f prepare \
+ || printf 'prepare ()\n{\ncd "luajit-2.0-${_commit::7}"\n}\n'
+ } \
+ | sed '
+ 3 a patch -p1 -i "$srcdir/c7815e1a1b49871e645252bb12e722fb4879df11.patch"
+ '
)"
fi