Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-13 12:14:12 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-13 12:14:12 +0200
commite7daceeef5e9edd33a4b85b016681a574af2a5ce (patch)
tree5f356b839901ce68db6d42a249d70aa9575fa2ec /community
parent6836f2ac1f07b7350713e06af1a19c0abbe93b9e (diff)
community/python-jaraco.context: bootstrapping
Diffstat (limited to 'community')
-rw-r--r--community/python-jaraco.context/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/python-jaraco.context/PKGBUILD b/community/python-jaraco.context/PKGBUILD
new file mode 100644
index 00000000..b0d7bd85
--- /dev/null
+++ b/community/python-jaraco.context/PKGBUILD
@@ -0,0 +1,18 @@
+# temporary to build python-build with python-bootstrap (breaking cycles)
+makedepends=(${makedepends[@]//python-build/})
+makedepends=(${makedepends[@]//python-installer/})
+makedepends=(${makedepends[@]//python-wheel/})
+makedepends+=('python-bootstrap')
+depends=(${depends[@]//python-jaraco.functools/})
+depends=(${depends[@]//python-jaraco.context/})
+depends=(${depends[@]//python-jaraco.context/})
+depends=(${depends[@]//python-autocommand/})
+depends=(${depends[@]//python-inflect/})
+unset checkdepends
+unset check
+eval "$(
+ declare -f build | \
+ sed '
+ s/python -m build -wn/python -m build -wn -x/g
+ '
+)"